Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Storage & Archiving QNAP TVS-871T Permissions and Disconnect Issues

  • QNAP TVS-871T Permissions and Disconnect Issues

     Marco Feil updated 1 month ago 3 Members · 7 Posts
  • Nate Haustein

    June 11, 2020 at 10:11 pm

    My small team and I have been editing in FCPX from a QNAP TVS-871T for about 4 years now. It’s been a great asset, but in the last 6-12 months I’ve been having more and more issues with odd Final Cut library behaviors, including force closes, and random disconnects. I’ve contacted QNAP support but they’ve ghosted me three times now when trying to remote in. I need help. And over the years, this forum has consistently been my #1 form of info on my QNAP system. Here goes…

    Some background.

  • TVS-871T has 8x 6TB drives in RAID6. There is also a TX-800P expansion with 8x 6TB drives in RAID6. Each enclosure hosts a single big share folder.
  • 2 Editors on Catalina Macs (OS X 10.15.5), connected directly to the 2x 10GBe ports on the TVS-871T via QNA-T310G1T Thunderbolt 3 to 10GbE Adaptors.
  • Connecting to QNAP via NFS. Each editor has their own account and is also in the administrator group.
  • Regularly update firmware on QNAP. Problem has persisted for a number of updates now.
  • FCPX on latest version 10.4.8 and storing media inside the library.
  • – – –

    Not really having issues with initially connecting, but more so randomly disconnecting, or having FCPX give an error saying that it can no longer write to the library. This typically happens when creating a new event or project in the library. I’m trying my best to learn permissions but I’m pretty confused about how to go about setting and maintaining proper permissions.

    For example, inside QNAP’s File Station, some of the libraries have my own user name listed as the owner and permission as 777, but others are owned by “501” which is what I’m assuming to be FCPX over NFS? Really looking for guidance on this whole aspect of things, and how to maintain it over time.

    It’s gotten to the point where I’ve backed up all of my footage on external RAIDs and am prepared to wipe everything out and start fresh. Thank you in advance to anyone who can help me start to sort this all out.

    – – – –

    P. S. I tried using SMB the other day and when opening older libraries that need to be updated in FCPX, it straight up sends the Original Media folder to the trash. I didn’t have the network recycle bin set up on the QNAP TR-004 share folder I use for archive so the files were lost. Terrifying.

  • Bob Zelin

    June 12, 2020 at 1:19 pm

    Hi –
    you should have been using SMB and not NFS since FCP X 10.3, when Apple started to support it.

    Your disconnects to the QNAP are due to the macOS. I will call you in 2 hours, and give you the
    fix for your Mac’s for this. You install the fix, and reboot your Mac. End of problem.

    Call you around 11:00 EST.

    Bob Zelin

    Bob Zelin
    Rescue 1, Inc.
    [email protected]

  • Marco Feil

    December 12, 2020 at 2:18 pm

    Hi Bob!

    What is this fix this you have? those nvram settings, server perfomance mode?

    I think our Catalina users have the same problem and nothing seems to help.

    Qnap 1685 connected via NFSv3. I’d love to switch to SMB but that isn’t too easy a task because of UTF NFC/NFD encoding issues.

  • Bob Zelin

    December 12, 2020 at 4:36 pm

    yes – its the serverprefmode=1 fix. If you need it I can post it again here.

    Apple started to support SMB with FCP X 10.3. That was years ago, NFS is a mess, and

    the leading expert of NFS, Marcel Bresink, always complains about how Apple has been handling NFS, which is not at all !

    http://www.bresink.com/

    I have no “fix” for you if you continue to use NFS. I have weaned all my clients off of it. I used NFS at the beginning of FCP X, because Apple was not supporting SMB at the time, but that changed with FCP X 10.3. And now with Big Sur, I have been telling my clients – STOP using AFP, because this is the beginning of the end. There will be no more AFP, just like there was no more FCP 7, and no one wanted to hear that. Stop using NFS. If that is not an acceptable solution to you – then I do not know what to say.

    Bob Zelin

  • Marco Feil

    December 12, 2020 at 9:42 pm

    Yeah… I’ve had plans to switch to SMB since 2018, but sadly its a bit complicated to switch with millions of NFD encoded file and folder names. And NFS worked ok until Catalina happened. Plus no time to really research that stuff and actually do it.

    But now that our 1685 seems to die, we’ll have to move everything to another NAS soon anyway. No better time than a catastrophic storage failure to do such a transition. Happy holidays to me I guess.

  • Bob Zelin

    December 13, 2020 at 3:06 pm

    your 1685 seems to die ?

    really ? I bet there is nothing wrong with your TS-1685. Since you are going to move everything to another NAS, setup the new NAS ( I do this for a living), transfer your data onto the new NAS with Hybrid Backup Sync, wipe out the TS-1685, rebuild the RAID group (static volume), create a SMB shared folder, and you will be fine. Once you stop using NFS you will be fine. I am telling you, this is going to apply to all the guys that are still using AFP, and simply refuse to switch over to AFP. And when Apple kills it (it’s kind of killed right now with Big Sur), they will cry. IS this any different than the guys that refused to stop using FCP 7 ? Nope !

    Bob

  • Marco Feil

    December 14, 2020 at 10:06 am

    Nope, there’s some kind of hardware problem, randomly crashes every couple of weeks, reboots, marks disks as faulty. Already swapped RAM. Yesterday I changed the power supply, hopefully that solves it.

    We have daily backups to a backup NAS via Hybrid Backup Sync. But HBS keeps the NFD encoding, so I’d be the same situation as I’m in now. Inaccessible folders via SMB.

    I guess I’d have to copy with rsync and –iconv=utf-8-mac,utf-8 options when I want to migrate to another NAS.

    At the moment I’m testing converting filenames with convmv again – it works, but doesn’t convert Aliases/symlinks – those are invisible via SMB, which is not that ideal when FCPX links to the original media via links in the library-bundle. Then relinking doesn’t work in FCPX because the links are technically there. Deleting the media folders containing the aliases inside the bundle or duplicating the library and then relinking seems to work – but thats what I’m testing today.

  • Viewing 1 - 7 of 7 posts

    Log in to reply.

    We use anonymous cookies to give you the best experience we can.
    Our Privacy policy | GDPR Policy