Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy ProRes 422 Color/Gamma Shift on Export – Same as Source

  • ProRes 422 Color/Gamma Shift on Export – Same as Source

  • Dustin Parsons

    February 8, 2012 at 12:56 am

    I can’t seem to export my ProRes 422 video from FCP7 without getting a color/gamma shift. Here’s the difference:

    The footage was originally H.264 from a Canon D5. I took the raw H.264 QuickTimes and converted them to Apple ProRes 422 using the preset in Compressor. I then took the ProRes clips into FCP7, dropped it in the timeline and set it to Same as Source, then exported a QuickTime movie using the Current Settings dialogue box (no QT conversion).

    Things to note:
    • In FCP I have my render codec set as Same as Sequence Codec and Always Render in Best Quality

    What I’ve tried so far:
    • In FCP I’ve tried exporting with the Gamma Correction set to Automatic and None (found in the Sequence Settings > Quicktime Video Settings > Advanced)
    • In FCP I’ve tried exporting with the Video Processing set to Render 10-bit material in high-precision YUV and RGB
    • In QuickTime I have tried toggling Final Cut Studio Color Compatibility and the shift still happens – it’s worse when I have it unchecked.

    Any suggestions for what I’ve done wrong or what I should try next? Thanks!

  • Matt Lyon

    February 8, 2012 at 7:47 am

    Hi Dustin,

    Have you tried bringing the exported clip back into FCP and A/B’ing it on a timeline with the original footage? That would probably be a more accurate way of checking the footage then comparing the quicktime window with the FCP viewer.

    That being said, I recall one situation recently where I had a similar issue and I had to check the “recompress all frames” options. Don’t know if that will apply to your situation, but worth a quick test.

    hth,

    Matt Lyon
    Editor
    Toronto

  • Chris Tompkins

    February 8, 2012 at 12:17 pm

    It’s just a setting in QT:
    There is a preference setting in QT/General tab/Enable Final Cut Studio color compatibility

    Chris Tompkins
    Video Atlanta LLC

  • Dustin Parsons

    February 8, 2012 at 6:00 pm

    No, the shift happens even when I have Enable Final Cut Studio color compatibility checked in QT – the shift is even worse when it’s unchecked.

  • Dustin Parsons

    February 8, 2012 at 6:35 pm

    [Matt Lyon] Have you tried bringing the exported clip back into FCP and A/B’ing it on a timeline with the original footage? That would probably be a more accurate way of checking the footage then comparing the quicktime window with the FCP viewer.

    Just tired that, and they look the same in Final Cut!

    Here’s a few more things I’ve tried:
    • Transcoding the ProRes clip into an H.264 (still got the color shift) and then uploaded that to YouTube where the colors looked correct
    • Opened the clip in MPEG Streamclip and the colors looked correct
    • Opened the clip in VLC Player and the colors looked correct
    • Opened the clip in QuickTime Player X and the colors had shifted just as they had in QuickTime 7

    So the problem is definitely with QuickTime because it’s appearing correct everywhere else. Has anyone run into this issue before? Even though the video appears to have the correct colorspace in other players, it’s still very important to me that it works in QuickTime because I’m pretty sure that’s what my clients use to view the cuts. Also, there just shouldn’t be a discrepancy like that.

    [Matt Lyon] I recall one situation recently where I had a similar issue and I had to check the “recompress all frames” options. Don’t know if that will apply to your situation, but worth a quick test.

    I just tried turning that on and exporting a new clip – it gave the same results as if I left it unchecked.

    Thanks for the comment! Any more troubleshooting ideas?

  • Matt Lyon

    February 9, 2012 at 1:48 am

    [Dustin Parsons] “So the problem is definitely with QuickTime because it’s appearing correct everywhere else.”

    The evidence is pretty damning, Dustin! I think your findings are pretty consistent with common complaints about the quicktime player that are routinely posted to this site.

    At least you know that FCP isn’t modifying the colors, and it’s just a QT Player display thing. I have read other posts about changing the “visual settings” in the video track options in the movie properties window in quicktime player 7. I haven’t played with it much myself, but you can search the forum and find more info.

    Can you ask your clients to view the clip in VLC? Maybe send a link to the installer download to make it easier for them? Or upload a file to Vimeo or YouTube for them to review? Honestly though, there are so many other display variables that might be happening on their machines that I don’t know how much it’s worth killing yourself over.

    Matt Lyon
    Editor
    Toronto

  • Dustin Parsons

    February 9, 2012 at 2:05 am

    I had run into this issue a few years ago when round tripping DVCPRO HD footage to AE but I thought it had been resolved… I guess it hasn’t been.

    I think you’re right – as long as the final product that the audience sees looks correct (which it will because it’ll be online), then I’m not going to kill myself over the QT color shift.

    Thanks for your help Matt!

  • Matt Lyon

    February 9, 2012 at 2:41 am

    Np Dustin. I just remembered when I had to use the “recompress all frames” options: it was when I had used a freeze frame in a pro res timeline. There was a shift from the original clip to the freeze frame when I exported a self contained movie. This was in fcp 6, so I’m not sure it still applies.

    Matt Lyon
    Editor
    Toronto

  • Dan Marlow

    February 9, 2012 at 6:01 pm

    Hi. Is there a PC involved at any point in the workflow?

  • Brittany DeLillo

    February 13, 2012 at 8:40 pm

    Not sure if this will help but it worked for a project I’m currently editing.

    If your sequence codec is set to ProRes, click on the “Advanced” button underneath it. There should be an option called “Gamma Correction”. Click on the drop down and change it from “Automatic” to “None”.

    The difference was night and day for me.

Viewing 1 - 10 of 17 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy