Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X Problem with FCPX 10.5 Libraries Updating in FCPX 10.6

  • Problem with FCPX 10.5 Libraries Updating in FCPX 10.6

     Patrick Donegan updated 2 weeks ago 4 Members · 4 Posts
  • Ken Bennett

    June 21, 2022 at 12:02 am

    I have just migrated from an iMac (Catalina)/FCPX 10.5 to a Mac Studio (M1 Max chip) (Monterey)/FCPX 10.6. I’ve opened up 2 Libraries and let them update in FCPX 10.6. However, the Libraries now have problems. In the timeline there are several missing video clips. That RED screen with the exclamation point is what I get. BUT the audio is OK!!! In my browser window in FCPX the video clips appear to be intact and have both audio & video. But some how the video is not appearing on the timeline. When I go look at the contents in the Library folder and look in the Original Media folder I don’t see all the video files. WHAT? How can these file disappear from the contents in the Library? I am now coping the original video files back onto my Mac Studio from a backup drive. So the original files are on my MS in a backup folder. How can this possibly happen and how can I fix it without major rework? If I just relink, everything “should” go back to what it was. Simple. But if the file I’m seeing in the FCPX browser is lying to me….. What’s the best way to repair without causing me a heart attack?

    I’m almost afraid to open up another Library in 10.6. that worked fine in 10.5.

    Help & Thank you

  • Mads Nybo jørgensen

    June 21, 2022 at 12:12 am

    Hey Ken,

    I can only think of couple of things that it might be:
    1) Video Codec is missing.
    2) FCPX/Mac is notorious for rendering media hard-drives useless, if you disconnect them with out using the “eject” command. If you have a back-up drive, I would back that up before using it.
    3) Maybe this is only happening to me, but I have in the past encountered a need to link each file individually to the project on a “new” Mac (when transferring Libraries from Producer to my work-station).

    Are you able to “roll-back” to FCPX 10.5 and check the project there?

    Hope that one of the above might work, or at least help you in the right direction.

    Good Luck.

  • John Fishback

    June 21, 2022 at 2:48 am

    I just had a similar issue. I opened an old Library in 10.6. After relinking files, I still had red frames in my timeline. What I discovered was certain Effects that worked in FCP 10.5 didn’t work in 10.6. Maybe it was the OS.

    Try opening the Inspector with a red clip selected, then one-by-one, uncheck the effects applied to that clip. Hopefully, one or more effects are out-of-date and you’ll be able to work with your Library. That worked for me. Of course, you’ll need a workaround for the effects that don’t work, if the developer doesn’t have an update.

  • Patrick Donegan

    June 21, 2022 at 5:11 am

    Oh, I hate when stuff like that happens on an upgrade.

    Did you copy the Library first or is it a 100 TB video library .. so not practical to duplicate aka backup you Library?

    Are there some small Libraries you can attempt first?

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy