Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Preview Max Time not working

  • Preview Max Time not working

     Jim Scott updated 1 month ago 3 Members · 11 Posts
  • David Cabestany

    June 21, 2021 at 8:55 pm

    I’m trying to limit the preview time on my timeline by limiting the work area to a specific range, much like it happens in After Effects by setting a beginning and end point, I even entered the min and max preview times manually in the project settings manager but when I play it back it reaches the end of the work area and continues to play after.

    Is there a way to limit the preview to only the work area?

  • Justin Thomson

    June 21, 2021 at 9:03 pm

    Enter the preview times in the preview range on the timeline. Or drag the handles.

  • David Cabestany

    June 21, 2021 at 9:14 pm

    “Enter the preview times in the preview range on the timeline.”

    That sets the beginning and the end of the project, not the preview. It could work as a workaround but it’s not an ideal way to work.

    “Or drag the handles.”

    I’m trying that and is not working, it just keeps playing after.

    Thanks for replying, I’m not trying to dismiss your advice, it’s just not solving the problem I have.

  • Jim Scott

    June 21, 2021 at 9:52 pm

    Based on your question, I concur with Justin. For reference, the frames visible on the ruler will match whatever the scroll bar has been adjusted to (141 to 237 in my example below). When the Play button is pressed it will loop through only those frames. If that’s not the behavior you’re looking for, or aren’t getting, please provide more info.

  • David Cabestany

    June 21, 2021 at 10:31 pm

    Yes, I also agree that that is was it’s supposed to be happening but alas, it’s not.

    Here’s my exact problem, I have a 15second long 24fps animation, that’s 360 frames. I changed the units to SMPTE so I could see seconds and frames on the timeline and not frames, it’s easier for me to time the animation properly that way.

    I’m trying to limit the preview range to play only from roughly 3:11 to 7:06 (83-174F).

    When I press play not only does the animation plays through the range mentioned above, but when it reaches the last frame of the range (174F) it continues to play forward, it does not loop back to the beginning of the range (83F). Further, when it reaches the end of the animation it starts all over from the very beginning, not the start of the preview range.

    It’s as if I hadn’t set a preview range at all. I wonder if there’s a preference or setting that instructs the software to completely disregard the preview range and just play the entire thing every time.


  • Jim Scott

    June 21, 2021 at 11:08 pm

    Interesting. When I set up a project as you described it works fine. I’m not aware of a preferences setting that would change that behavior, but there’s a plenty I don’t know about C4D. Just for grits, have you tried closing and reopening C4D? I assume your timeline looks like the image below.

  • David Cabestany

    June 21, 2021 at 11:09 pm

    Apparently, there’s something on my project causing this. I just tried a new scene with just a cube in it and the preview range works as expected.

  • David Cabestany

    June 21, 2021 at 11:15 pm

    Yes, I restarted the program a few times now but does not seem to help. Somebody suggested that I copy everything to a new empty scene but I’m not sure if that will help or just break something else. It’s not a super complex scene but I have layers, stage objects, guides, etc.

  • Jim Scott

    June 21, 2021 at 11:23 pm

    Copying everything to a new scene would have been my next suggestion as well. It shouldn’t hurt, since you’ll still have the original one. Other than that I’m at a loss. I’ve got to leave for an appointment, but I’ll try to play around with it later and see if I can find anything. Good luck.

  • Jim Scott

    June 22, 2021 at 10:58 pm

    I think I have found your issue. In the “Animate” menu in “Preview Mode,” see if you have “Preview Range” unchecked. That needs to be enabled in order for playback to use the defined preview range. See screenshot below, and one from the Help files: (If the image isn’t fully visible, click to open it)

Viewing 1 - 10 of 11 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy