Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums VEGAS Pro Preview Lag / Preview Hiccup

  • Preview Lag / Preview Hiccup

    Posted by Kelly Griffin on May 30, 2023 at 6:55 pm

    Hey all–

    I just upgraded from Vegas10 to Vegas20 (Windows 10):

    I’m noticing a very evident lag between picture and sound when previewing on an external HDMI monitor with “Best > Full” selected, even when just playing a single video/audio event with no FX applied. Is there some kind of a CPU optimization checkbox in Preferences or something that might be amiss?

    Also, oftentimes when I select the external monitor preview button it either (1) takes several clicks on and off of the external monitor icon for anything to show, or (2) will only display a still from an initial timeline cursor point but just sits there after pressing play, or (3) won’t display anything at all.

    Any thoughts about what’s up?

    Thank you!

    –Kelly

    Aivis Zons replied 1 year ago 3 Members · 2 Replies
  • 2 Replies
  • Hector Vera

    May 30, 2023 at 7:16 pm

    If you have an option for GPU Accelerator, I suggest you try that out since it renders your Vegas video a lot faster than the normal one and pre-rendering your videos within Vegas so you can see a preview without lags before you render it!

    Also what is the specs on your computer? Cause if it’s lagging this much, may be the CPU/GPU requirements.

  • Aivis Zons

    May 31, 2023 at 1:34 am

    GPU acceleration should be detected and enabled by default if available. You can check if it is by going to Options -> Preferences -> Video -> GPU acceleration of video processing -> select your GPU if it’s there. If it isn’t, it might be worth a shot to update your drivers, restart and check again. If it’s still not there and it’s just “Off” then either you don’t have a dedicated GPU or your model might not be supported. Might be worth trying to reinstall Vegas at that point or do a system restart if you didn’t after driver update.
    Additionally check the File I/O tab and see if your GPU shows up in the first two dropdown menus. It should be set to your GPU, not “Off”.

    Next thing you can check is in Preferences -> Preview Device. There’s a checkbox for “Optimize GPU display performance” – it should be ticked.

    Beyond that the only remaining option in my mind would be to use dynamic RAM previews. Create a loop region of the footage you want to preview, press Shift+B and it should start building a RAM preview. Once done it should playback much smoother, but it will be limited to the region you selected. The size of the region might shrink automatically if you haven’t allocated enough RAM for this operation (Options -> Preferences -> Video -> Dynamic RAM Preview) – I’ve set mine to 40% of total memory and in 99% of cases that works fine for me.

    Alternatively maybe just don’t use Best (Full) playback, try Best (Half) or lower…

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy