Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro Premiere/Speedgrade EDL issue?

  • Premiere/Speedgrade EDL issue?

  • Angelo Lorenzo

    June 4, 2012 at 9:54 pm

    In Premiere I’ve created a 24fps timeline (24fps straight up, not 23.976) and the timeline timecode display is also set to 24fps.

    If I export an EDL and open it in Speedgrade, I’ll notice that some clips in the edit have time stretches.

    If I export the same EDL, but first set the timeline timecode display to number of frames, the issue is fixed.

    Am I missing something with how Premiere deals with EDLs? I’ve had some issues with Speedgrade not dealing with drop vs non-drop correctly.

    If the timecode display setting affects the export of EDLs then is Premiere’s 24fps setting, really some variation of 23.976? Adobe’s help file isn’t clear at all on this.

  • Angelo Lorenzo

    June 4, 2012 at 11:17 pm

    There was an error in my troubleshooting. It looks like both EDLs (display timecode vs display frame number) look perfectly fine.

    I’m not going insane, since I’ve used EDLs a number of other times in all kinds of applications.

    I tried testing the one offending clip in a 23.976 and 24fps timeline, and even with a simple one clip EDL, Speed grade adds a 100.5% time stretch to the clip.


    The problem was fixed, however when I set Speedgrade to interpret the EDL as 24fps and the footage as 23.976.

    The footage originated from a RED Epic shot at 24fps with a timebase of 24fps…. I’ll have to check and see if there was a dropped frame issue or, if during the transcode process Redcine-X interpreted the timecode as 23.976… which would be a bug on their end.

    A little more troubleshooting awaits.

  • Chris Borjis

    June 6, 2012 at 10:17 pm

    thanks for posting this Angelo.

  • Angelo Lorenzo

    June 7, 2012 at 6:10 am

    Looks like it’s a bug with Speedgrade.

    -The EDL is exported at 24fps
    -The footage timecode is 24fps
    -Speedgrade’s project and footage settings are both set to 24fps

    So why is Speedgrade losing a frame?

    I’ve reported it as a bug, but am I wrong? Premiere also reimports the EDL and shows a footage duration of 10:28:00:05 – 10:28:08:14 so it’s losing a frame there too. Frustrating.

  • Angelo Lorenzo

    June 7, 2012 at 8:07 am

    I retract that, it appears that it’s an issue with how Premiere exports EDLs.

    Let me explain:
    EDLs use inside/outside cuts.

    If I have a clip that goes from 18:03:36:04 to 18:03:47:20, the EDL displays it as 18:03:36:04 to 18:03:47:21 since the out cut is outside of the wanted frame; it’s always plus +1.

    Premiere, apparently freaks out over certain ranges. The offending EDL had a clip range of 10:28:00:05 to 10:28:08:15 and the EDL reflected 10:28:00:05 to 10:28:08:15… off one frame. Other programs think it’s an outside cut and dump one frame making the end point 10:28:08:14.

    Looks like I just have to be hyper vigilant of the issue and edit my EDLs by hand. The real question is why does this happen seemingly randomly?

  • Angelo Lorenzo

    June 7, 2012 at 8:56 am

    Anddddd the issue doesn’t exist in Premiere Pro CS5.5, just CS6. That’s why I haven’t come across it until now.

  • Chris Borjis

    June 7, 2012 at 5:59 pm

    adobe update now shows SpeedGrade 6.01

    might try that update and see what happens.

  • Angelo Lorenzo

    June 7, 2012 at 7:04 pm

    Same issue. I actually went into each media clip, cleared the in and out points, and then recut the same in and outs and replaced the clips on the timeline. Problem solved, but it freaks me out that there was no concrete reason behind what happened.

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy