Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Premiere Pro Premiere can’t see mapped drives (anymore)

  • Premiere can’t see mapped drives (anymore)

    Posted by Christopher Hill on September 20, 2016 at 6:35 am

    –I’ve posted this in the Official Adobe forums as well, but haven’t gotten any responses yet. I’m hoping I have more luck here.

    Our office works in a network environment with several NAS storing projects and assets. We have never had issues with mapped drives being recognized in Premiere (and in fact everyone else in the office still doesn’t have any issues). We have just had a new EditShare DAM system installed and as part of the training I was trying to drag assets/sequences from EditShare to Premiere but it wouldn’t let me.

    **SIDE-NOTE** this is not an EditShare issue. I only point that out to show how we discovered the issue.

    I then noticed that in the Premiere Media Browser none of the mapped network drives were showing up and neither were their non-mapped network locations. I have read through the issues and solutions presented in this thread Link Media on Network drive in Premiere Pro CC as well as the links to the other threads pointed to in Post #2 of that thread. I am running on Windows 10 (fully updated).

    I have a similar setup at home, Win10 (updated) and PPCC 2015.4 (fully updated). I opened Premiere there and I can see the mapped drives on my network just fine. As I mentioned the other 2 editors and the 2 producers can still see mapped drives in Premiere just fine.

    In fact when I went to open a project I was working on last week by double-clicking on it from within explorer (from the mapped drive) I was presented with this error:

    Not sure what that \\?\ was, so I disconnected all mounted drives, and then remounted them. Still no good. I then opened a command prompt and did a “net use /persistent:no” and cleared all drive mount persistence then disconnected and remounted all the drives. Again, no dice.

    Oddly enough I was, at one point, able to open the old project I had been working on but only after I performed “Sync Settings” from the Premiere opening splash page and only by double-clicking the project file (couldn’t browse to it on the network or mapped drives once inside premiere). Regardless, it still didn’t recognize any of the media. I was able to re-link all the media by unchecking the “Use Media Browser to locate files” but that still doesn’t solve the issue of not seeing mounted drives. I can’t open any projects from within Premiere on a mounted drive and I can’t see any mounted drives in the Media Browser.

    To add additional confusion, After Effects and Media Encoder both see my mapped network drives no problem!

    • My account at work is an Administrator account (as is my home account)
    • I have tried running Premiere as an Administrator, even setting it to always run as Administrator
    • I have uninstalled and reinstalled Premiere twice (once leaving the preferences, second time deleting preferences)
    • I have restarted the PC multiple times
    • The firewall is disabled for both private and public networks
    • Windows Defender is also disabled (as I read that could create issues)
    • This functionality is working fine for the other two editors and two producers in the office
    • It’s working fine for me at home
    • It’s working fine in ME and AE and (oddly) working fine on my laptop on the same network

    Many of the people in threads I’ve read say that Premiere just isn’t meant to function on a network and everything should be done locally. I don’t need to hear that please. It’s been working fine ever since we upgraded to CC 3 or more years ago. I’ll mention again that it’s working as it should for my 2 editor colleagues, my two producer colleagues and for me at home.

    If anyone has any other suggestions though, I’m at the stage where I’ll try anything short of a reformat (I really don’t want to do that).

    Brie Clayton replied 8 months, 1 week ago 7 Members · 7 Replies
  • 7 Replies
  • Alex Udell

    September 20, 2016 at 11:46 am

    There is definitely something odd going on if you are the only one in a group seeing the issue….

    I’m not sure of the FIX….

    but maybe this will help as a temp work around

    you could dry to make a symbolic link to you netowork location on you C:/ Drive

    windows has a command called mklink

    here’s a video on it:

    one the link to the remote location is created….

    then In PPro you’d only need to browse to the C:/ path

    The OS then SHOULD handle the see thru of the network location.

    I’m not suggesting this is a FIX…..but it might get you going if you are losing productivity or are up against a deadline.

    I’ve been environments where mklink was used in situations where Volume mapping was inconsistent….

    (where network locations didn’t always get the same drive letter from machien to machine)

    by using mklink…. it was always based on C:/YOUR_FOLDER_NAME

    that way it was always the same from machine to machine….

    hth some….

    Alex Udell
    Editing, Motion Graphics, and Visual FX
    Let’s Connect on Linkedin
    Examples: Retail Automotive Motion Graphics Spots
    Example: Customer Facing Explainer Video
    Example: Infotainment & Package editorial

  • Michael Krueger

    June 8, 2017 at 3:11 pm

    Hi Christopher,
    this problem seems to be an UAC issue on some Windows machines and connected to how access tokens for mapped drives are handled.
    What worked for me was enabling linked connections via the registry editor following these instructions:

    1. Click Start, type regedit in the Start programs and files box, and then press ENTER.
    2. Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
    3. Point to New, and then click DWORD Value.
    4.Type EnableLinkedConnections, and then press ENTER.
    5. Right-click EnableLinkedConnections, and then click Modify.
    6. In the Value data box, type 1, and then click OK.
    7.Exit Registry Editor, and then restart the computer.

    Hope it helps.


  • Christopher Hill

    September 15, 2017 at 11:34 am

    Michael! That fixed it!

    It actually fixed another mapped drives issue I was having as well, so kudos to you. Thanks very much for the help (and sorry for the late reply). 🙂

  • Mike Petersen

    August 21, 2020 at 1:45 pm

    I know this is old now but I just came here to say thanks, I had the same problem and this method resolved it!


  • Richard Dufty

    June 25, 2021 at 10:26 am

    Still works! Just fixed the same problem for me in After Effects 2021.


  • Davina Hader

    September 18, 2023 at 12:48 am

    Thanks, it still works and just fixed my issue with Adobe products too! 🙂

  • Brie Clayton

    September 18, 2023 at 2:40 pm

    Thank you, Michael, for this enduring solve!

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy