Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer OS Avid Compatibility

  • OS Avid Compatibility

  • Trevor Ambrose

    September 29, 2021 at 6:40 pm

    Hi Folks,

    I want to update my OS but I don’t want to alienate my Avid.

    My current OS is: 10.9.5

    My current Avid is: 7.0.4.3

    If I update my OS to the most current version, will I still be able to use my Avid?

    Any help would be appreciated!

    Trevor Ambrose

    https://www.imdb.com/name/nm0024430/

    My Mac is:

  • David Budnetz

    September 29, 2021 at 7:03 pm

    media composer 7 is ancient. If you want to upgrade to a recent version of macos, you are technically hosed.

    Please refer to the media composer version matrix for further details:
    https://avid.secure.force.com/pkb/articles/en_US/Compatibility/en267087

  • Pat Horridge

    September 29, 2021 at 8:16 pm

    Version 7 Avid definitely won’t work with Big Sur!

  • Chris Bové

    October 2, 2021 at 11:29 pm

    Hi Trevor.

    Don’t upgrade yet. The most current version of the macOS is BigSur 11.6.0 and the highest version o Avid MC currently runs only on macOS 11.5.2 which you cannot get right now. I’ve been seeing lots of issues with BigSur 11.6.

    That being said… Your MC7 app will not work at all on Catalina or Big Sur. You would need to either buy a new perpetual license, or get a subscription.

    For reference, go to a website I’ve created to understand all of the Avid version environments: http://www.alwaysediting.com/avid-mc-versions.html

     

    Chris Bové

    Online Community Manager

    Avid

     

Viewing 1 - 4 of 4 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy