Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Object Light in viewport not visible in render

  • Object Light in viewport not visible in render

     Brian Jones updated 1 week, 1 day ago 2 Members · 5 Posts
  • Bennette Sebastian

    September 12, 2020 at 1:53 am

    I have a scene set up with a model group designed to look like a car emblem on a painted black body panel. The idea is to pass a few object lights over the surface to accentuate the modeling. The object light is a parametric plane with an illumination material. Ideally, the object light reflections would be visible in the materials for the emblem and panel.

    I can’t figure out how to get the object light to show up in the preview and render. In the viewport, I can freely move the the light object around and see the reflection clearly in the car model. I’m using an HDRI material for a garage look, and that’s coming through nicely in all the materials.

    I’ve tried:

    -Rendering GI in both physical and standard renderer

    -turning light intensity up

    -increasing reflectance and specular in all materials

    -poring through render settings for GI and pretty much everything else

    Objects in the scene, visible in these pictures, have no assigned material and are showing the object light just fine in preview and render. I made a new material and just changed the color to black, using default settings for everything else. Even this material won’t show any reflection of the object light. I feel like this must be a render setting, but I don’t know what else to check.

    I’d really like to figure this out. Thanks for your help.

    Cheers, B

  • Brian Jones

    September 13, 2020 at 4:03 am

    in your example images, it’s hard to see what’s in front of what really… the orange thing (which I assume is the logo) is reflecting the lights up above. You really have to do any reflection ‘searching’ through the camera, if not it’s too easy to miss as it has to be lined up perfectly to be seen.

    Or your luminant plane only has the texture on one side or something. You might have to post the scene.

  • Bennette Sebastian

    September 14, 2020 at 5:55 pm
  • Bennette Sebastian

    September 14, 2020 at 6:02 pm

    Ah, so dumb. I had “Limit reflections to sky” checked on in render settings. PIBKAC

  • Brian Jones

    September 14, 2020 at 11:54 pm

    thanks for the follow up

Viewing 1 - 5 of 5 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can. Our Privacy policy | GDPR Policy