Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer New to Avid – Issues with trim mode

  • New to Avid – Issues with trim mode

  • Shawn Stevens

    November 3, 2018 at 10:10 pm

    Hey,I started an Avid tutorial this week. I’m fluent in premiere. I’m at the section in the tutorial where they talk about trim mode. The problem is every time I click the “Trim Mode” button and then click back into the sequence it automatically switches back to “Source/Record Mode.” The trim mode icon won’t even show up instead of the mouse clicker. Any thoughts?

  • Shane Ross

    November 4, 2018 at 1:32 am

    If you click on the timeline bar, that deactivates trimmode

    Shane
    Little Frog Post
    Read my blog, Little Frog in High Def

  • Trevor Asquerthian

    November 4, 2018 at 6:10 am

    Not sure what your question is? You are not able to stay in trim mode?

    My tips on trim mode:

    Assign/learn shortcuts for-
    trim, src/rec, effect & ccr modes (I use F2/F3/F4/F5)
    toggle trim sides
    trim 1/many frames
    Previous/next edit
    Extend (this is quickest way for simple trims)
    Top & tail (like Q & W in PP)
    Head/tail fades (for quick audio fades esp dialogue/music edits)

    rather than mousing around.

    Learn to select different sides to (asymmetric) trim

    Alt& trim mode takes you back to trim mode *with* previous trim sides selection

    Learn how extend works. No need to select an edit like PP, obeys mark in (or out) and track selectors.

    It’s totally worth the effort to get keyboard approach sorted, Avid trimming is the major thing I miss in PP.

  • Katy Skjerping

    February 20, 2020 at 3:37 pm

    Hi –
    I’m on MC 2018.12.1 on an older iMac. Not remotely new to Avid.

    Can not for the life of me get the assymetrical trim mode to work in this version!

    In the older versions of MC I am able to go to trim mode and then option select the opposite side for various tracks. (For example: video the roller is on the a side and for two tracks of audio the roller is on the b side so that when I trim I am trimming the tail of the video and the head of the audio simultaneously)

    Currently, I am only able to get symmetrical trim mode (in other words, rollers are all on the same side for all tracks) Option/Selecting the tracks in this version simply toggles ALL rollers to the opposite side.

    What am I missing!

    Thank you
    KS

  • Will Oswald

    April 26, 2021 at 11:03 am

    Yes it drove me nuts too. It is button at the top of time-line that links “synced” clips, called lined selection toggle. The Icon looks like 3 horizontal bars and a chain link down the right side. Try toggling it off. Only took me an hour to find:)

  • Glenn Sakatch

    April 27, 2021 at 5:15 pm

    For the original question.

    Go into trim mode, the click on your record monitor, or your source monitor, or in-between them. This will rotate you through the base trims.

    Note how your sync locks are turned on and off, as this will affect which tracks you trim.

    Then select a clip on your timeline, and the enter trim mode. This will give you another option on trimming.

    Once you get the basics down, then start playing with all the other options listed above.

  • Will Oswald

    April 27, 2021 at 7:14 pm

    Absolutely correct but my point was that if that button is selected it no longer behaves as you describe. It may have been some help to trying to get back to the conventional way of working.

    Regards!

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy