Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Mountain Lion & FCP7

  • Mountain Lion & FCP7

  • Mathew Milani

    November 27, 2012 at 6:19 pm

    Hi there,

    I just did a clean install about a month ago for all my editing apps having moved to mountain lion,

    For FCP7 You must do a clean install (with Apple Discs) or it will not work. I tried DMGs wont work…

    FCP7 seems to be working fine it does have a few issues but that would due to 3rd party plugins as far as crashes are concerned. I even was surprised to see a pro app update from 2010 appear in my app store!

    I would recommend trashing thumbnails every other day or if you get a crash.

  • Bruce Tokars

    March 12, 2013 at 11:11 am

    I recently installed FCP6 on my new MacBook Pro using Rosetta and to my surprise and delight it installed and works! Then came the downside.

    Something in the install has broken every app that I use to download streaming video. Jakstra, iShowUHD, and others I have tried all try and load but end up crashing.

    I have not seen any reports of this problem and am stumped as to what could have caused it and how to fix it. I assume that I could uninstall FCP6 and all of the full suite’s parts but that might not fix it. Has anyone here had this issue? Yes, I know that Apple says the Mt Lion won’t let you run FCP 6 or 7 but clearly many of us have found that is not the case

    This is a rather strange issue and may related to QuickTime. I’ve also been getting an error occasionally from Safari that the QuickTime Internet Plug-in is missing. But I can’t find anything about that issue either except that others have seen the same message,

    Any thoughts on any of this is appreciated.

    Thanks.

  • Mathilde Nègre

    April 26, 2013 at 1:15 pm

    Hi !
    I have another problem, maybe you ll know what I could do.
    I updated my system to Mountain Lion 3 days ago, I worked since 3 days on Finalcut 7.3 and everything was ok, I created new projects, opened old one, everything just worked fine.
    2 hours ago I tried to open a project and FCP7.3 just crashed before opening it. Now it seems to be impossible to open FCP, I desinstalled and reinstalled FCP, but it’s still the same, and I can’t understand what happened.
    Please help me if you know something about my problem !
    Thank you

  • John Craddock

    August 9, 2013 at 1:40 pm

    We have had a similar experience with ML and FCP7. We upgraded about a month ago to 10.8, everything was working smoothly, then unexpectedly, Final Cut would halt on startup. It would get to the point where it was profiling for RT, then simply disappear. There is nothing in the crash logs, it just disappears on startup. We tried using some cleanup utilities to remove all of the Apple ProApps from the system and reinstalling FCP7, and the same thing happened. Then a clean install of 10.8 and a clean install of FCP7; same problem. Today we’re retrograding the workstation back to 10.7 and plan to keep it there until the end of time, or at least until our editorial staff is up to speed on Smoke. We’re not the only people on the interwebs who are having this problem.

  • Steve Mullins

    September 26, 2013 at 11:15 am

    I too have crashes with FX Factory plugin – have updated to the latest ML version – seems ‘broken sprocket’ effect causes big issues with rendering – even some pixels in the finished render (if it doesnt crash that is).

    Solution – avoid certain plugins – I’m going to do a clean install of FCS3 – probably remove FCX too.

    Annoying as SL was fine – but FX Factory has got new effects with the lates ML version…

  • Bill Latka

    October 1, 2013 at 3:57 am

    Part of the problem you’re experiencing could be (according to the “helpful” folks at Apple tech support) the recent firmware updates that have come with ML. The firmware updates could be working some kind of voodoo with FCP 7.0.3. Their suggestion to me was to attempt to install FCP on a Lion partition, but since they don’t support downgrading, I’d be on my own with that.


    Bill Latka
    Rivet Entertainment
    Building awareness.
    Building change.

Viewing 21 - 26 of 26 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy