Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Mountain Lion & FCP7

  • Mountain Lion & FCP7

  • Chris Paul

    July 26, 2012 at 4:28 pm

    Finally nailed down the problem to having outdated Boris Continuum Complete plugins. I updated them and now FCP7 boots. My final advice is to not upgrade to Mountain Lion in mid-project. If you are not going to do a clean install, make sure you have a backup so you can restore to a working system. I love to try the latest stuff so I have a boot drive dedicated to that so I do not risk my working system.

    Chris Paul
    POV

  • Jesse Coane

    July 26, 2012 at 7:29 pm

    Just tested iChat theater in mountain lion and it also works (didn’t with Messages beta).

    Director / Editor
    http://www.jessecoane.com
    @jessecoane

  • Jake Jones

    July 26, 2012 at 11:18 pm

    Final Cut pro version 6 seems to be working fine on Mountain Lion. Thank goodness. I was pretty scared.

  • Lance Moody

    July 27, 2012 at 1:07 am

    Do you mind stating your procedure for getting iChat theater to work? I couldn’t get it to work at all.

  • Christopher McDonell

    July 27, 2012 at 4:05 pm

    [Jake Jones] “Final Cut pro version 6 seems to be working fine on Mountain Lion. Thank goodness. I was pretty scared.

    Thanks Jake. I love it!

    Now is everyone here actually doing a ‘clean’ install and is it really necessary? What’s the method? This –> ?

    1. Use Digital Rebellion FCS Remover
    2. Upgrade Lion to ML
    3. Perform clean install of FCP via discs, update all software

    ???

    Chris

  • Simon Knight

    August 15, 2012 at 8:33 pm

    Hi everyone,
    Just thought i’d give you my experiences from today regarding FCP7 and ML.

    I am running a late 2007 iMac on Snow Leopard. This is my edit machine with FCP703 on it.
    Late last year (2011) i splashed out on a MacBook Air. It had Lion on it and I thought it would be my way of testing and running either FCPX or Adobe PP.
    After backing away quickly from iMovie Pro (sorry) I resigned myself to getting to grips with Premier Pro. Its been fun but i haven’t really been as productive and find when I need a quick and easy edit I run back to the good old FCP7. I also have to capture my Sony Z5 stuff to the iMac anyway…

    Last week I upgraded to Mountain Lion… ok, I was bored..!

    So today I thought I’d give it a go and loaded up FCP7. And then Motion. And then Color.
    All worked exceptionally smoothly. Then I got the App Centre telling me there were Pro App updates available. So I gingerly downloaded it all. And got a smoothly running FCP7.0.3.

    Oh what the hell… Go on then… Magic Bullet suite…. All running. All stable. All very quick with the SSD drive. In fact the only slow part of the process is the external 1TB drive as a scratch disk. Perhaps an SSD is called for to finish it off.

    Ok so as a workstation its not brilliant on a 11.3″ screen. But for continuing an edit on the road and now with the ability to capture through the Thunderbolt-FW800 cable Apple has released, it is working really well.

    So thats a native Lion machine, upgraded to Mountain Lion and THEN FCP7 loaded… No crashes yet!

    Good luck out there… seems its a very quirky OS, indeed..!

    MediaHound Films
    http://www.mediahoundfilms.co.uk
    07775 233 730

  • Cris Cazor

    September 17, 2012 at 1:29 am

    Hi Dave and everyone else,

    Havent heard from anybody discussing about a brand new Macbook pro with ML and installing FCP7.
    So would the newest MBP with ML run clean and fast Final 7.
    Havent bought the machine yet, my old MBP 2008 just died (logic board), so i was thinking about doing a huge upgrade and before spending a few bucks on that toy, wanted to know about suggestions or experiences with a good, new and clean computer.

    Thanks for all your posts.

    Cris Cazor
    cfssb.org
    Santa Barbara, CA

  • Ryan Whiting

    October 8, 2012 at 6:55 pm

    I just got off the phone with Apple Tech Support who told me FCP 6.0.6 is NOT compatible with ML (10.8.2) – (I have tried installing and it won’t open for me).

    How did you get this to work???

    Appreciate your input

    Ryan W.

  • Christopher McDonell

    October 9, 2012 at 6:08 am

    Ryan, you probably need Rosetta. I found it online somewhere. Find it, download it, and you should be good to go.

  • Ryan Whiting

    October 9, 2012 at 7:52 pm

    Thanks Chris ~

    Any idea where i can find it???

Viewing 11 - 20 of 26 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy