Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro X Monterey and FCPX

  • Monterey and FCPX

     Claude Lyneis updated 1 month ago 4 Members · 7 Posts
  • Kev May

    October 27, 2021 at 7:18 pm

    Hi All,

    Unfortunately I’ve upgraded to Monterey and FCPX isn’t playing well with it. If I touch the timeline with the curser, it crashes the computer and it shuts down. When I restart the computer, I’m having the same issue.

    Has anyone else had this problem with Monterey and FCPX and if so, have you found a solution?

    Thanks for any help that you might have and it’s very much apprecaited!!

    Kev

  • Roger Sherman

    October 27, 2021 at 7:21 pm

    Apple has a Pro App number that includes FCPX. They’ve been very helpful.
    866.752.7753

    Good luck.

  • Kev May

    October 27, 2021 at 7:23 pm

    Thanks Roger and I’ll give them a call!

  • Joe Marler

    October 28, 2021 at 10:29 am

    If MacOS crashes, that is either an OS-level bug, a 3rd-party kernel-mode driver or a latent hardware problem which surfaced upon an OS upgrade. In general, an app cannot cause an OS crash and there is no fix possible for an app to avoid that. This case would be likely better handled by MacOS support, and if directed to Pro App support they would just hand it off to them.

    It also makes sense to examine the system config, such as % of free disk space remaining, what external hard drives are in use, also any 3rd-party kernel mode drivers. Starting with Catalina the terminal command to examine those kexts changed, and is now:

    kmutil inspect | grep -v com.apple

  • Kev May

    October 28, 2021 at 4:10 pm

    Hi Joe!

    Thanks so much for your insight and input and it’s greatly appreciated.

    We tried downloading Monterey a second time with the same results. Of course having eight million projects that I’m working on and not having time to screw around with it, my IT guy took me back to Big Sur and we are all good to go and I’m back up and editing once again.

    Down the road when things slow down, we can tackle this again when there is more time and not the pressure to get these projects done.

    Thanks again for your help and insight and it’s very much appreciated!

    Kev

  • Claude Lyneis

    November 2, 2021 at 3:09 am

    I just upgraded to Monterey from Mohave and have FCP 10.4.10 installed. Since I am making changes, I tried to upgrade to FCP 10.6. The APP store says all my Apps are current and I can’t seem to find anyway to get it to update. On the other hand 10.4.10 seems to run. Should I pursue this farther, or stay with 10.4.10 for a while? I am between projects, so I thought it was time to finally go full 64 bit.

  • Claude Lyneis

    November 2, 2021 at 3:53 am

    To answer my own question, I just trashed FCPX and Compressor and downloaded them from the APP store. That was all that was needed to get the current versions.

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy