Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro X Missing Keyboard command to show/hide libraries

  • Missing Keyboard command to show/hide libraries

    Posted by Rikki Blow on May 19, 2023 at 11:44 am

    I used to sometimes use the Command-Tilda combination in FCPX to show or hide the Libraries column. I can’t remember whether this was a default key command or something I customised, as I’ve been using it for years. I also only use it occasionally, so not sure if it has been lost in the last update or longer, but it’s weird I simply can’t find it in the customisation options to reinstate it, even though I’ve definitely been utilising it in my workflow for years. As you can see, showing ‘All Commands’ in Keyboard customiser, there is simply no option to Show/Hide Libraries. I can only show/hide the whole browser.
    Any thoughts?

    FCPX 10.6.5 OSX Ventura 13.3.1(a)

    Ben Balser replied 9 months, 1 week ago 4 Members · 8 Replies
  • 8 Replies
  • Chris Northcross

    May 19, 2023 at 1:46 pm

    You can remap the command to any key you wish. I set mine to the F1 key.

  • Doug Metz

    May 19, 2023 at 9:32 pm

    I didn’t know that was even a thing… so what did it do, just hide the library icon in the browser?

    I wasn’t able to find it either (I’m current).

  • Ben Balser

    May 20, 2023 at 7:51 pm

    The default to “Show/Hide Browser” is Control-Command-1.

    The default to “Show/Hide Library Sidebar” is Command-tilde.

    Be sure you have the Default command set active.

    Everything works fine for me in macOS 13.3.1(a) and FCPX 10.6.5.

  • Rikki Blow

    May 22, 2023 at 2:10 pm

    Yes Doug, it hides the left hand column ie where your library name(s) and its events are, so giving more room for the list of clips if you’re in a particular event and marking them up.

    For some projects and workflows I find it quite useful.

    I can do the same thing with a mouse-click of course, and the tool tip still displays as ‘Show or hide the Libraries sidebar’, but it always used to be set as the Command-Tilde in the Default set, and in my own edited set I had left it like that.

    It no longer works, but also it doesn’t appear as an option (as per my screenshot) so I CAN’T remap it to get it working again. Alphabetically it should be showing between Show/Hide Keyword Editor and Show/Hide Marked Ranges. (ie Show/Hide Libraries sidbar) – Perhaps Ben can confirm this?

    I assumed it had disappeared in the latest update, but Ben is on the same versions of OSX and FCPX as me apparently, so the plot thickens.

    I’ve tried switching back to the Default commands, but it’s not working there either, AND it still doesn’t appear as a customisable command in the Command Editor, which is the real mystery for me.

    I wondered for a sec whether there might be something wrong with my overall keyboard mapping or even the tilde key, but I can type tildes in TextEdit, and all keys with shifts and options seem to be doing what they’re supposed to, so I’ve ruled that out.

    Obviously I’m not alone if Doug can’t see it as a command option either. What a strange quirk (and a bit annoying). I can live with using the mouse instead, but I’m really intrigued why it’s gone.

  • Ben Balser

    May 22, 2023 at 2:35 pm

    1, Go to System Settings > Keyboard > Keyboard Shortcuts, click “Restore Defaults” (system shortcuts override app shortcuts).

    2, Hold Opt-Cmd while launching FCPX, delete preferences.

    Here’s my screenshot of the FCPX commands default set, when I do a search for “sidebar”.

  • Doug Metz

    May 22, 2023 at 5:39 pm

    Ahhh, I misunderstood the OP. I have and can see Show/Hide Sidebar, and it works as expected.

    I got hung up on the word Library specifically, and wondered why you’d bother to hide library icons, but retain the events / keywords.

  • Rikki Blow

    May 22, 2023 at 8:54 pm

    So your screenshot has helped some. I was looking for Show/Hide Library sidebar (which is what the tooltip calls it) but now I can see on your image that the Command Editor just calls it ‘Show/Hide Sidebar’, and yes it’s there, and seems to be assigned correctly. BUT I’ve noticed the keyboard layout looks like a different language, and maybe this is the problem. But now the trouble is I haven’t a clue how to change it back to an English QWERTY keyboard. It seems to be FCPX specific – as mentioned above, all keys work as expected in TextEdit, graphics apps, Word etc., so it’s not a system-wide setting. There’s an option in System Settings to customise a language setting for a particular app, but in my case it’s empty and FCPX isn’t mentioned.
    So that’s a whole other can of worms, but in the meantime I’ve reassigned the Sidebar command and it’s working fine for me on a different key combination, so I won’t have to reset prefs especially as I’m in the middle of several projects and don’t want any other changes to happen right now.

    Thanks as always to the kind folk who try to help out on this great forum.

  • Ben Balser

    May 22, 2023 at 9:20 pm

    FCPX and most apps use the system setting for keyboard layout.

    Did you restore defaults in system settings?

    If you have an issue like that, I’d reset FCPX preferences for sure, doesn’t hurt anything, and could prevent other issues.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy