Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro X Media missing if no car is inserted, once inserted all files are in the libary..

  • Media missing if no car is inserted, once inserted all files are in the libary..

    Posted by Dominick Verstoep on December 2, 2023 at 1:09 pm

    Hi,

    For 2 projects I experience the following issue:

    When I open the fcpx project it says for about 70% of the clips that they are missing,

    When I insert the card with the original footage its no longer missing and when I ‘reveal in finder’ they are within the libary content.

    So when I eject the card and try to link them it says they cannot be linked since the media cannot be found.

    I tried inserting the card and consolidate media but that also doesnt work since it errors that all media has been consolidated already.

    Is anyone experiencing the same issue?

    Rikki Blow replied 3 weeks, 4 days ago 8 Members · 11 Replies
  • 11 Replies
  • Craig Seeman

    December 2, 2023 at 7:55 pm

    Somehow you managed to leave files in place when importing from a card I believe. Normally that shouldn’t be possible from a camera card. In your case, FCP thought it was an external drive. You may have to put in the card and then use FCP’s Consolidate function to move the media to an always-connected drive.

  • Dominick Verstoep

    December 5, 2023 at 12:33 pm

    Hi,

    No it imports the files to the libary but once I eject the card it gives me a red screen.

    When I insert he card I cant consolidate because it says there is nothing to consolidate.

  • Doug Metz

    December 5, 2023 at 7:30 pm

    It certainly sounds like you’ve imported with ‘leave in place’, since it’s looking for the card.

    What you may be seeing in the Library package are aliases to the clips on the card. Check the sizes of the files in the Library without the card.

  • Craig Seeman

    December 5, 2023 at 11:53 pm

    I second what Doug says. It’s not importing into the Library. It’s likely leaving aliases point to the card. Please post a screenshot of your settings.

  • Dominick Verstoep

    December 10, 2023 at 11:33 am

    We found the solution,

    We use a gigantic dropbox account to save projects offline when needed and online when not needed. Dropbox moved to the Apple File Provider API and it does not allow them to fully sync fcpx projects so dropbox is corrupting the files.

  • Patrick Donegan

    December 20, 2023 at 8:37 pm

    Very interesting DropBox behavior.

    Please send all this to the DropBox techs so they can know this issue exists.

  • Mads Nybo jørgensen

    December 21, 2023 at 3:20 am

    DropBox is a pain in the preverbial when working on large scale projects.
    Constantly had it conspiring with FCPX to download random files from a client’s very large DropBox folder (We are talking PBs, not TBs..!).
    And when you put them back to be in the cloud only, DropBox would keep those files on my Mac SSD for three days in secret location as temp-files type files.

    DropBox support was excellent to give me a fix. But a button on the interface could have resolved it.
    Yes, to keeping your working Library well away from DropBox, and have it on your local drive.

    Atb
    Mads

  • Patrice Freymond

    December 21, 2023 at 12:10 pm

    I would use Postlab for this

  • Rikki Blow

    March 14, 2024 at 10:32 pm

    I’ve had the same problem a occasionally without any Dropbox factor involved.

    I ALWAYS import to library, so there’s no way the ‘leave files in place’ would be ticked on.

    After importing from a card from a Lumix GH5S M2, I came back to the project the next day and files are missing as per OP’s description. And like them, when I reinsert the camera card and try to relink or consolidate, I can’t because FCPX is telling me there’s nothing TO consolidate and the files ARE in the library. But if I remove the card, they disappear again.

    My only solution has been to delete them completely while card removed, and then re-import.

    It seems to be an occasional corruption quirk, and in my case nothing to do with DropBox. It just happened a few days ago, but before that maybe once every few months (I do a lot of short form projects, so possibly like 1 in 40 or so affected). I’ve never worked out what causes it – it seems very random and I’ve just used the delete/reimport workaround.

  • Ben Balser

    March 15, 2024 at 2:30 pm

    “No it imports the files to the library but once I eject the card it gives me a red screen.”

    You’re not waiting long enough for the files to import completely. Open the Background Task window when importing to verify the import is complete before ejecting a card. It takes quite some time for video files to import from cards, and is NEVER an instantaneous process.

    Give a screen shot of these clips in the FCPX Browser, with the card inserted, I bet it shows they’re not completely imported. I’ve seen this happen quite a bit.

    Also, check your FCPX Settings > Import, be sure that shows files to be copied into the Library, not left in place. This affects imports when you do drag-and-drop. But even if you don’t drag-and-drop, it’s a good idea to have it set up properly for your needs, anyway.

Page 1 of 2

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy