Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Media Encoder Media Encoder CC – H.264 pixelated result

  • Media Encoder CC – H.264 pixelated result

  • Mark McGrotty

    May 6, 2014 at 5:09 pm

    Hi,

    I’m having some issues with getting a decent image out of H.264 720p preset with Media Encoder. The lossless file rendered with After Effects is sharp and looks exactly how I want it. However, encoding with h.264 (which I need it to be) provided a very lossy pixelated file.

    You can see comparisons here:

    Original
    screenshot2014-05-06at17.45.12.png

    H.264
    screenshot2014-05-06at17.44.51.png

    This is the first time I’ve ever came across this, as h.264 has worked perfectly for me in the past. I’ve even cranked the bitrate upto 20 but still get, pretty much, the same result. So any help with this would be awesome.

  • Ivan Myles

    May 6, 2014 at 9:16 pm

    What is the format of the lossless file? Is there a lot of motion in the shot?

    Here are a few things to try:

    – In the Multiplexer tab be sure MP4 Stream Compatibility is set to Standard.
    – In the Video tab select: H.264 format; Level 4.1; High Profile; VBR, 2-Pass; 20 Mbps target bitrate; 40-62.5 maximum bitrate; key frame distance set to half of frame rate; enable Maximum Render Quality

    Also: What is the frame rate? 20 Mbps is plenty for 24-30fps, but might not be sufficient at 60fps.

  • Mark McGrotty

    May 7, 2014 at 8:56 am

    Thank’s for those pointers, they did help somewhat. The original file is just an uncompressed animation file.

    The background texture is pretty detailed and there is a fair amount of animation going on. I’m going to try going back into the original texture eps file to make a bit simpler as I suspect the transparency there is causing a few issues too. Just strange I’m not seeing it in the uncompressed render.

  • Ivan Myles

    May 8, 2014 at 2:22 am

    H.264 is compressed significantly more than QT Animation. Try exporting a short clip with the following settings to verify whether there is an encoding issue:

    Video Tab:
    – Format: H.264
    – Level: 5.0 or 5.1
    – Profile: High
    – VBR, 2-Pass
    – Target Bitrate: Max
    – Max Bitrate: Max
    – Maximum Render Quality Enabled
    – Maximum Bit Depth Enabled
    – Key Frame Distance: 1/2 of frame rate or about 10-15 frames

    Multiplexer Tab:
    – MP4
    – Stream Compatibility: Standard

  • Ed Hecht

    January 27, 2016 at 6:21 pm

    Thanks, Ivan. This was the answer to a confounding H.264 problem for me as well!

  • Chester Boyes

    October 14, 2016 at 10:03 pm

    Im having the same problem, can not figure it out. Im stitching together a time-lapse sequence so each of the frames is really high quality. When i export just the jpeg files with no effects or anything added in AAE this is the output result. (The screen shoot is about 1/4 of the full shot)

    Settings are as follows:

    Any ideas would be greatly appreciated!

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can. Our Privacy policy | GDPR Policy