Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer MC 8.9.4 with dongle

  • MC 8.9.4 with dongle

  • John Thomason

    March 19, 2021 at 12:51 am

    My system stop working and it keeps saying that applications manager is unable to connect to avid server I am on 8.94 what can be done to get back up and running. I am right in the middle of a project that has to be done by Monday HELP HELP. I am using a IMAC with macOS 10.13.6 High Sierra I use a dongle This is the same system for the last few years and I have not had a problem. HELP WHAT CAN BE DONE

  • sean hanley

    March 19, 2021 at 3:34 am

    Hi – It could be system maintenance with Avid. Try looking at this – https://community.avid.com/forums/t/134768.aspx?PageIndex=4

  • Pat Horridge

    March 19, 2021 at 7:30 am

    I think that was the reply from Avid on your post on the Avid forums.

  • John Thomason

    March 20, 2021 at 12:03 am

    That was the answer I got from the avid forum. I tried it and it did not work I purchased a Perpetual license 8.9.4 so I would not have to upgrade and it has been working great for years I don’t know what happen and to upgrade it know it will cost $1400.00 that is just not in the cards for me. I don’t know where to go from here. it looks like I am not going to make my dead line

  • John Thomason

    March 20, 2021 at 11:33 pm

    some how my system is not seeing my dongle . Now I need to find a dongle updater for version 8.9.4 any suggestion on where to find it

  • Glenn Sakatch

    March 21, 2021 at 5:51 pm

    If you log in to your account with avid, you should be able to update…or call support, they will usually handle license issues.

    Nobody Else can give you a dongle updater..it is tied to your dongle

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy