Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects Maya into After Effects Error

  • Maya into After Effects Error

  • Matthew Dawydchak

    April 11, 2005 at 3:44 pm

    so I went through this tutorial to get my Maya camera into After Effects and I keep getting this error:

    After Effects: AEGP Plugin MayaImport: Error reading Maya file.
    ( 5027 :: 12 )

    now I’ve noticed that all the tutorials and explanations I’ve found online refer to Maya 4 and After Effects 5.5, and that might suit me fine if I was using either vesion of the programs. but I’m using Maya 6 and After Effects 6.5. has anything changed since these tutorials were written? I’m using Windows 2000 on this machine if that helps find an answer at all.

    …would really like to know.
    thanks

  • Lars Bunch

    May 23, 2005 at 9:06 pm

    Hi,

    I just got the same error message. I am running AE 6.5 and Maya 6.5 on a Mac OS-X 10.4.1. Up until now, I never had a problem importing maya files into AE, but I recently set up a new graphics system and upgraded the OS. The mayaimport plugins are in the proper place, so I’m not missing them. And since this is a mac rather than the above mentioned windows 2000 system, I assume it’s not an upgrade issue.

    I just tried importing a maya file that I know worked in the past and it still works. Seems to be something in the way the more recent file was saved.

    Anyone have any clues?

    Lars

  • Lars Bunch

    May 23, 2005 at 9:11 pm

    Hi again,

    Here’s an update: I looked at the Maya file and I had a couple of references to bring in other props. Two references were unloaded. When I deleted all references and resaved the file, AE imported it properly.

    Maybe that’s the issue… I don’t know…

    Lars

  • Paul Roper

    June 10, 2011 at 5:57 pm

    Six and a bit years later, I just had the same problem and a search brought up this thread. I suspected it was the references causing the problems, so I unloaded them, but the problem remained. But I hadn’t actually REMOVED them – after removal, the .ma file loads fine into AE. So yes, as you suspected all those years ago, it was the references causing the trouble.

    I just thought I’d add this to the thread in case anyone else comes across the same problem. Would have been nice if Adobe (or whoever wrote the Maya import plugin) might have improved things since then, or at least made the error alert box a bit more helpful! I’d have thought it would be fairly easy to adapt the import plugin to completely ignore all parts of the scene file other than the camera(s) – after all, that’s the only thing that actually gets imported anyway.

    But I’m still VERY HAPPY that AE has the ability to import Maya’s camera data!

    Paul

  • Brock Jolet

    December 17, 2013 at 8:22 pm

    Two and half years later I’m having this same issue. I’m not sure what you guys mean by “references.” My scene has a camera with baked keys and an aim null also with baked keys. After Effects just doesn’t like it.

  • Paul Roper

    December 17, 2013 at 10:21 pm

    Eight and a half years! A pretty long time for this thread – and a horribly long time for an error to still be hanging around.

    I’ve moved over to Cinema 4D now – it works much better with After Effects, so haven’t used the Maya import workflow for a long time.

    But in response to your references question – references are Maya models that are linked into another scene. For example:

    I have five scenes, all containing a table, a chair and a person. Instead of importing the table, chair and person, it’s much better to reference them, so if the client says “I want the table to be taller”, you can open the model of the table, change it, and because your five scenes only reference (are linked to) the table file, they automatically reload it and are updated. It also means file sizes are much smaller – you’re not storing the same data five times. It is a fantastic way of working on all but the simplest of scenes, and now I’ve moved to Cinema 4D I really miss it. Cinema 4D is completely and utterly bloody hopeless at references. Very annoying, seeing as it claims to be a pro-level piece of software, and using references is one of the most basic, essential tasks and the concept has been around for many decades – I remember using AutoCAD in the early 90s and setting up very complex, multi-level nested references with absolutely no problems at all.

    – Paul

  • Paul Greer

    November 7, 2014 at 10:33 am

    Hello.

    I use this feature a lot and then the issue came with a scene I just working on. I tried many different things and eventually realised it was the scene that was triggering the problem. I wondered if it had picked up a glitch that AE didn’t like.

    So my fix was, To make a new fresh scene, import the previously exported camera (the one AE refused) then to export it again from there. Then it worked.

  • Omar Hernández

    December 23, 2015 at 5:09 pm

    I’ve been using the feature for a long time and just today I ran into the error.

    The difference, in my case, is that I’m using Arnold as the main render engine.
    I deleted the flags about Arnold (attributes .aovs and such) in the .ma and it worked!

    Omar H

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy