Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple OS X Major Catalina Catastrophe

  • Major Catalina Catastrophe

     Jim Curtis updated 8 months, 2 weeks ago 5 Members · 9 Posts
  • Jim Curtis

    May 7, 2020 at 2:43 pm

    Sorry for the long post, but I’ve tried to provide the relevant facts.

    My 2019 MacPro stays on more or less constantly, but I shut it down Sunday night when I heard thunder approaching. I routinely do this to protect my gear from spikes, even though I have it an my RAIDS (I have two.) connected to a APC UPS. On Monday morning, after I booted, I noticed my desktop had changed, Mail wasn’t working right, and my Contacts had disappeared. This wasn’t the first time this has happened with Catalina. So, I reinstalled Catalina after booting from a recovery flash drive, and then copied my User Folder from the clone I made Saturday using ChronoSync. That restored my boot disk, or so I thought.

    I then noticed several catastrophic facts: Almost all the projects and media on my two RAIDs had been erased. I also noted several third party apps had vanished from my boot disk.

    I have two RAIDs on my Mac because I’m paranoid about data loss. The smaller 24TB OWC TB3 DAS RAID is intended as temporary backup to the 126TB QNAP NAS RAID until I can backup to an LTO tape. I lost around 50 TB of files. Freakout time!

    I have three suspicions about what happened.
    (1) malware attack. I ran the CleanMyMac malware finder, and it found no incidences.
    (2) total FUBAR of Catalina 10.15.4
    (3) Prior to shutting down Sunday night, I tried to make a LTO tape using ArGest Backup 4.0.6. I dragged a folder into the backup area and clicked Continue. Then a window came up in which I DESELECTED Estimate Archive Size, and then clicked the button to proceed. The app ignored my desire to Estimate, and proceeded to list thousands of files. This went on FAR LONGER than I’d ever seen, but I was going to let it run. After about five minutes is when I heard the thunder, so I force quit the app (with no other way to interrupt the process), and shut down my computer, NAS and RAID.

    Since I reinstalled Catalina and my User folder on Monday morning, I probably destroyed any logs that might have helped me to determine what I can blame this on with any degree of certainty.

    If anybody has any theories, I’d love to hear them. And, I’m also posting this as a warning to other Catalina and perhaps ArGest users to be careful. I hate to indict any innocent parties here, but as you know, if you’ve been dealing with computers long enough, the last thing you did before a meltdown is the most likely suspect.

    It’s possible that Catalina was whacked first, then cascaded an issue with ArGest Backup, or vice versa, creating a perfect storm.

    Epilog: I searched for an app to un-delete files, and DiskDrill has been finding files for the past two days, and I’ve been able to restore MOST of the projects and media I hadn’t yet written to tape. I still have hours to go before I’ll know if there’s any corruption of my files, or how much. DiskDrill works on my OWC RAID, a DAS via TB3, but it DOES NOT recognize the NAS, which mounts as a shared disk. That’s cause for concern.

    Jim Curtis
    jamesphilipcurtis.com

    MacPro7,1 24-core – 256 GB RAM – AMD Radeon Pro Vega II 32 GB – 10.15.4 (Warning: Don\’t do the Supplemental Update!)

  • Jim Curtis

    May 18, 2020 at 12:57 pm

    No comments, eh? It was the length, wasn’t it? Or, you all think I’m nuts, and this never happened?

    Now that some time has passed, and I’ve had time to attempt to deduce what went wrong, I’m concluding that this catastrophe was a perfect storm of a shitty OS and some beta software.

    This is based on the fact that right before I shut down, and started to run a job with ArGest Backup, the Estimate Size was displaying hundreds of file names (which is usual), but it went on for about five minutes, (which is UNusual – usually takes 30 seconds or less). It’s my theory that ArGest and Catalina were working in tandem to delete files willy nilly. I did a force quit, and shut down my computer (due to lightning and thunder nearby). It was after I booted in the morning that I noticed my issues. It’s usually the last thing you did that caused your problem.

    ===

    I just reinstalled Catalina for about the seventh time, due to multiple Finder hangs over the weekend. I got the spinning ball for about a minute or two after doing something routine like clicking on a disk icon, or renaming a folder.

    Over the weekend, I upgraded my old ATTO SAS Enhance RAID with eight 12 TB SATA drives. Now, I have two massive RAIDs, and I can keep one switched off when I’m not doing backups, which should protect it from any future similar catastrophes. BTW, this old RAID kicks ass on my QNAP NAS in terms of io – about 40% faster read and writes according to the BMD disk speed tester.

    Jim Curtis
    jamesphilipcurtis.com

    MacPro7,1 24-core – 256 GB RAM – AMD Radeon Pro Vega II 32 GB – 10.15.4 (Warning: Don\’t do the Supplemental Update!)

  • Rainer Wirth

    May 19, 2020 at 9:09 am

    Hi Jim,

    I have read it but didn’t know what to say,
    because whats happened to you is horrible.
    I wouldn`t even want to think about it.
    I just thought: What lucky I was never touched Catalina and what a mess
    for people who are stuck with it. Especially when you bought a new macPro
    for a couple of thousands of dollars.
    I hope you can cope with it

    cheers

    Rainer

    factstory
    Rainer Wirth
    phone_0049-177-2156086
    Mac pro 8core
    Adobe,FCP,Avid
    several raid systems

  • Robert Withers

    June 11, 2020 at 4:25 pm

    Thanks Jim. I guess one moral is to unplug the Catalina even when the computer is shut down. (During a thunderstorm). And thanks for the word about Diskdrill.
    I’m “stuck” with a Catalina imac. I guess one has to pick up a 2018 machine to run Mojave.
    Sympathies, though. I have to re-cut parts of a vintage Adobe Pr Pro “2013” project that somebody helped me recover.
    Best,
    Robert

    Robert Withers

    Independent/personal/avant-garde cinema, New York City

  • Jim Curtis

    June 12, 2020 at 11:38 pm

    Hi Rainier,

    I still haven’t determined exactly what caused the massive file deletion. I eventually got a reply from Tolis Tech support who claimed it was “impossible” the Argest Backup had anything to do with files being deleted. I’m skeptical, because the app will definitely overwrite files if you tell it to. I understand why nobody would want to take the blame for something so catastrophic.

    Since writing this post, I reinstalled Catalina for what I estimate is the eighth time. That’s become a standard practice when the Finder starts acting strangely, which has become a too common occurrence. In the process, the installer upgraded me to 10.15.5. Once it gets to 10.15.6, it will get to where I’ve learned that OSX is approaching reliability.

    Also, since first posting, I’ve installed a two drive 16TB RAID 0 internally (using that Promise kit for MacPro7,1) for daily backups from my big RAID. So, I’ve got a total of four RAIDs. I can keep two switched off (and unplugged) most of the time, and that should keep my media safer. Plus, I also have the LTO drive. I may sell my 128 TB QNAP NAS. Seems unnecessary.

    I’ve increased the frequency of my boot disk cloning. Since I’ve had my User folder vanish two or three times now, not going too long between cloning seems prudent.

    Thank you for replying.

    Jim Curtis
    jamesphilipcurtis.com

    MacPro7,1 24-core – 256 GB RAM – AMD Radeon Pro Vega II 32 GB – 10.15.4 (Warning: Don\’t do the Supplemental Update!)

  • Eric Santiago

    June 13, 2020 at 5:51 pm

    Jim your patience is amazing.
    I got two 2019 MPs here and haven’t had to re-install Catalina to date since delivery.
    You are my inspiration 🙂

  • Jim Curtis

    June 13, 2020 at 6:08 pm

    Haha. You weren’t around when I turned the air blue after discovering my unfortunate situation, Eric.

    The good news is that I’ve got Gb fiber, so a reinstall takes about 20 minutes, which is far faster than my experience with all previous versions of OSX.

    Unless I’m mistaken, there are no utilities to fix broken directories that Disk Warrior or Drive Genius could fix prior to APFS. So, short of Apple Disk Utility and the shells that run it underneath, reinstalling Catalina is the only way to fix Finder issues that Disk Utility can’t, AFAIK.

    I got excited to see that Drive Genius came up with an update for Catalina, but Directory Repair still isn’t supported for Catalina. So, I passed upgrading it. I have CleanMyMac X, which I still run a few times a week (and is a better deal, IMO than Drive Genius, although it does fewer things, like defragging, which I’ve never done on any disk, anyway). It does the Disk Utility Repair and other maintenance tasks, including Repairing Permissions, which has vanished from Apple Disk Utility, or so it says.

    Not having a working system is a deal-breaker according to my clients, a situation shared by most of us on this forum, I would suppose.

    May The Force be with you and your new Macs and Catalina.

    Jim Curtis
    jamesphilipcurtis.com

    MacPro7,1 24-core – 256 GB RAM – AMD Radeon Pro Vega II 32 GB – 10.15.5

  • J Hussar

    June 25, 2020 at 5:48 pm

    My guess is it was in the Chronosync phase. It might have sync’ed incorrectly? I’m a fellow sufferer with a 2019 Mac Pro and stuck with Catalina – not moving off 10.15.3 until the bug mess is fixed. 10.15.2 was all kernel panics. Lost mail. Lost data. etc.

    My approach has been to disable all security and that T2 chip. Gateway disabled, SIP disable, Security of T2 disabled, and allow boot from external drive (set in recovery mode).

    At this point only rare crashes. Apple is more dangerous to me than viruses! Ha!

    Apple’s walled garden is a Gulag. Sick of the consumerization of the computer/workstation space. I’ve been with Mac’s since the beginning.. Now really, actually, considering an escape – especially if this ARM chip transition culls what is left of the real pro software. Tim makes me nauseous.

  • Jim Curtis

    June 25, 2020 at 8:41 pm

    It wasn’t ChronoSync I was using at the time, it was ArGest Backup – my LTO archiving and restore app. However, I concur that it was probably at least complicit in this catastrophe.

    I’ve had nothing but good luck with ChronoSync. I’ve been using it to sync my RAIDs for years. I’ve always had two RAIDs. Now, I have four. And I try to keep two of them turned off at all times, so this never happens to me again. I plan to sell my smallest RAID this weekend. Four is overkill. ☺

    I haven’t had any KPs lately. I got a few within a week of receiving the MacPro, and I was probably on 10.15.2 at the time. I’m on 10.15.5 now, and I haven’t had to reinstall the OS since the last time, that brought me up to 10.15.5 from 10.15.4.

    I forget how I did it – likely something in the Security settings, but I can boot off an external SSD I have attached via USB-C.

    I’ve been all Mac, too, since upgrading from my Commodore 64. I feel hostage to it, given my considerable investment in software. Now, I’m too close to retirement to consider switching. I got eight years service out of my MacPros 2008 and 2012.

    As for the lost mail and other Catalina horrors, that’s why I clone my boot drive every few days now. Having an SSD as a clone speeds that process up considerably. Takes about 15 minutes using the SuperDuper Smart Update feature.

    Jim Curtis
    jamesphilipcurtis.com

    MacPro7,1 24-core – 256 GB RAM – AMD Radeon Pro Vega II 32 GB – 10.15.5

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy