Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects Keylight on green causes white artifacts

  • Keylight on green causes white artifacts

  • Travis Dao

    November 13, 2012 at 1:15 am

    Hi all,

    I’m keying DVCPro HD footage shot in a green studio with Keylight. The key creates some white artifacts around parts of the talent. It’s most noticeable around the groin area (unfortunately) and where the arms meet the torso.

    Does anyone know what is causing this and what I can do to eliminate the white artifacts?

    Thanks!

    TD

  • Darby Edelen

    November 13, 2012 at 4:11 am

    Hard to say exactly but usually when Keylight goes wrong it has something to do with the despill color correction. You can disable this part of the pipeline by using the ‘Intermediate Result’ instead of the ‘Final Result.’ Try that and see if the problem goes away.

    If it does you’ll need to despill your footage by another method. I like to duplicate the footage, use the Channel Mixer effect to clamp the Green values at a combination of the Red & Blue values (start at 50% Red and 50% Blue) and set this to the ‘Darken’ blend mode above the keyed footage. That’s always given me a great result.

    You may also try toggling the ‘Unpremultiply Result’ checkbox to see what you get.

    Darby Edelen

  • Travis Dao

    November 13, 2012 at 6:17 am

    Thanks for the response.

    I tried untoggling the “Unpremultiply Result” checkbox but nothing changed.

    Do you mean to adjust my Keylight values to the “Intermediate Result” and use that as the key?

    I wonder if there is an issue using DVCPro HD keying with my computer. It’s strange that the key would cause white artifacts just around the legs and arms. I did a search on the internet and couldn’t find anyone else posting the same problem.

    Thanks,
    TD

  • Darby Edelen

    November 13, 2012 at 7:04 am

    There is a drop down that usually defaults to something like Final Result (my wording may be off there), try changing that to Intermediate Result (again, might be off there). This is the same key as the Final Result with no color correction/despill applied.

    An image might help diagnose this, a project file with a still problematic frame might help even more 🙂

    Also if you’re viewing at anything but Full resolution in the Comp Viewer you should see if this also appears at Full resolution.

    Darby Edelen

  • Travis Dao

    November 13, 2012 at 7:35 pm

    I tried using Intermediate Result but it just changes the white artifact a little green. I’ve attached a screen shot of what I’m seeing.

    4959_whiteartifacts.png.zip

    I put the person on a red background so you can see the white artifacts near his groin and where his arms meet his body.

    Thanks,
    TD

  • Darby Edelen

    November 13, 2012 at 7:48 pm

    Lower your Screen Despot Black value. This runs a Median (smoothing) operation on parts of the matte. What you’re seeing is the smoothing of the sharp angles in the man’s pits/groin.

    Darby Edelen

  • Travis Dao

    November 13, 2012 at 8:05 pm

    Funny you say that I was playing with that setting when you responded. It’s already set to 0.0 unfortunately I can’t set negative values. If I increase it a gray band extends from his groin. Do you know of any other way I can remove it?

    Thanks,
    TD

  • Darby Edelen

    November 13, 2012 at 9:13 pm

    Reset your values to default, except the screen color, and let us know if you still see it. If not then it’s one of the screen settings, screen pre-blur maybe, otherwise it looks more like a footage problem.

    Darby Edelen

  • Travis Dao

    November 13, 2012 at 11:34 pm

    You’re right it is one of the screen settings. I reset the other values and it came down to screen pre-blur and the clip black settings as the culprits. I can lose the white artifacts but then I lose some of the person. He’s standing in front of a grid with two shades of green (unfortunately there was nothing I could have done about it). That’s probably what’s causing me these issues with the key. How would you go about keying someone in front of two shades of green?

    Thanks for your help you’ve really helped me along.

    TD

  • Darby Edelen

    November 13, 2012 at 11:53 pm

    [Travis Dao] “How would you go about keying someone in front of two shades of green?”

    Well, that definitely complicates things 🙂 I’d start by trying to treat them separately. Duplicate the footage, create a mask for each shade of the screen with some overlap in the center then key each instance separately. The overlapping area will be the hardest to manage. To get a clean edge it might require some fairly gnarly roto work.

    Darby Edelen

Viewing 1 - 10 of 17 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy