Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Premiere Pro keyboard shortcut for “Render in to out”

  • keyboard shortcut for “Render in to out”

    Posted by Jim Watt on November 30, 2015 at 3:03 pm

    What has happened to the keyboard shortcut for “render in to out”? In PP CC 2015 it seems to have disappeared which requires going to the drop down menu to use it, which is a very slow way to do business. I’ve searched for it in keyboard shortcuts and it’s not there and it definitely was there in 2014.

    I’ve been dealing with this ever since 2015 came out and just now had time and the inclination to ask if anyone knows how to make a keyboard shortcut for “Render in to out”.

    thx…Jim Watt

    Chris Gomersall replied 8 years, 6 months ago 4 Members · 7 Replies
  • 7 Replies
  • Trent Happel

    November 30, 2015 at 9:39 pm

    In Keyboard Shortcuts, go to Application > Sequence and Render In to Out should be the third item listed.

    Trent Happel
    Premiere Pro

  • Jim Watt

    December 1, 2015 at 12:51 am

    Hi Trent,

    Thanks for the note, but that’s not exactly the case. I spent some time back & forth with Colin Brougham from Adobe and we determined that it’s a bug and in my system it’s not there on two different machines. We found a work around by using the keyboard shortcut for render entire work area, when the work area item is not checked in the drop down menu.

    This is the link to that discussion:


  • Trent Happel

    December 1, 2015 at 1:37 am

    Did not realize this was being discussed on the Adobe forum. Good to know and that you and Colin got to the root of the issue and found a workaround.

    Trent Happel
    Premiere Pro

  • Chris Gomersall

    December 1, 2015 at 2:38 pm

    Creating one yourself in the keyboard editor is easy.

    Kind regards,
    Chris Gomersall

  • Jim Watt

    December 1, 2015 at 2:51 pm

    It is easy if the option is in the keyboard shortcuts menu. It’s not.

    The folks at Adobe have acknowleded that it is a bug in PP CC 2015-2.

    If you know another way to create the shortcut, please share that wisdom.


  • James Strawn

    December 1, 2015 at 9:25 pm

    Here is some background info which may help:
    By default, the Enter key is mapped to ‘Render Effects In to Out’ or if you have the work area bar (WAB) enabled that will change so that enter is mapped to ‘Render Effects in Work Area’ (which is essentially the same thing, you’re just using the WAB to mark the range instead of in/out points). It’s been that way for a while now and it is more efficient for most users who don’t want to waste time rendering the whole range when all they really need rendered is some non-accelerated, applied effects within that range.

    There are 2 special cases could be confusing if you happen to notice it working differently without knowing why:

    (1) Morph Cut: is a GPU accelerated effect so it would generally not force the render bar red on a system with a capable enough GPU. But it still requires rendering to see the effect at full quality (which can actually change its appearance slightly in some cases) so we force it to turn red anyways so that users can easily render it just by hitting enter.

    (2) Optical Flow: Is a very GPU-intense sort of display. So when you apply this option to time-modified footage in the timeline you will see a ‘low quality’ preview unless you park on a frame and wait for the high quality interpolated frame to draw in (after about a second). So since users don’t want to have to park on every frame to see their newly interpolated frames, we also special cased this to force a render even though it’s actually using GPU acceleration he whole time as long as your renderer is set to use a GPU.

    That’s probably more info that you need, but I thought this was as good a place as any to explain some of these nuances to those who may have a vested interest. More to the point, as was brought out, you can always map your own shortcut to ‘render entire work area’ and ‘render in to out’ and it will render the whole range regardless of what color the render bar is.

    Also I wrote this because I’m going to test Trent on it later. (not really)

  • Chris Gomersall

    December 2, 2015 at 6:00 pm

    Opps. My bad. Brain farted. this works on 2014. Apologies.

    Kind regards,
    Chris Gomersall

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy