Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe After Effects Illustrator Files importing at 10% size in AE

  • Illustrator Files importing at 10% size in AE

    Posted by Claire Presnall on March 30, 2023 at 3:31 pm

    There’s only 1 discussion I can find about this over on the Adobe boards, and didn’t solve the issue, crickets everywhere else. I’m hoping someone has a solution.

    I have a 10620×72 Illustrator design file. It’s coming in at 10% size (so 1062×8) when I import (as footage, as comp, as comp retain layer size). I copied and pasted the layers to a new illustrator doc and it comes in just fine, but I have a BUNCH of these I’ve already divided up for animation, and Illustrator hates copy/pasting things and maintaining my layers (even with “Paste Remembers Layers” selected), so I’d love to solve the issue instead of having to redo all my work from yesterday slicing up these files.

    Thanks!!

    Joe Wood replied 10 months, 2 weeks ago 4 Members · 6 Replies
  • 6 Replies
  • Claire Presnall

    March 30, 2023 at 3:46 pm

    Stupid workaround:

    So after wasting 2-3 hours trying to figure out the “proper” way to do this, I just said “why not” and put my layers all inside the background layer (which is the full size of the board) and added a zero to the end of my art board size and my layer size. Everyone scaled up together, and when I bring my board into AE and it makes it 1/10 the size, it’s now the correct size.

    My AI file is now 106200px wide which seems excessive (and I thought was bigger than AI is cool with, but whatever, it worked). What a stupid issue and a stupid solution.

    If you know the proper way to fix this or a more elegant way even, please share!

  • Usama Aslam

    March 31, 2023 at 8:56 pm

    Hi Claire,

    Here are a few things you can try to fix the issue:

    Check the resolution settings when importing the file and make sure the “Import As” option is set to Composition (Retain Layer Sizes).

    Then, in the Composition Settings, dialogue box, make sure the resolution matches the resolution of your Illustrator file.

    Check the document settings to ensure that the artboard size and resolution are set correctly. Go to File, Document Setup, and make sure the “Units” are set to “Pixels” and the resolution is set to 72ppi (or whatever resolution you need for your project).

    Try saving the Illustrator file in a different format: If you’re still having trouble, save it as a PDF or EPS file, Sometimes different file formats behave differently in After Effects.

    You can also import the layers from your original Illustrator file into After Effects separately, rather than as a whole composition. This would allow you to maintain the layer structure and avoid having to copy and paste between files.

    Hopefully, one of these solutions will work

  • Claire Presnall

    July 12, 2023 at 6:35 pm

    Hi! Thanks for the thoughts, but sadly, I tried all of those before posting my initial question.

    It seems to be an issue folks randomly have per the adobe message boards, and so far, no one has figured out why it’s happening. And it’s so inconsistent! I’ll get multiple artboards in a single file that I send to individual files, so you’d think they’d all have the same settings. Some are wonky, and some import just fine.

    So it’s brute force scaling up in AI to 10x my size for me. 😢

  • Joe Wood

    August 9, 2023 at 8:58 pm

    I’m just encountering this now as well. Its killing my workflow. I read on the Adobe forums that if I copy and paste it to another Ai comp it will work, but it doesn’t seem to solve the issue for me.

    I really hope they address this soon though, it’s ridiculous. If you try and save legacy or older, it even pops up a disclaimer that it will be read 10x smaller. Looks like any way I save it, its 10x smaller though.

  • Eric Santiago

    August 10, 2023 at 1:20 am

    Any chance someone can send me an example of the AI file?

    Curious to see where it fails.

    I work daily with AI vectors designed by a large graphics team and AE.

    Not once I’ve run into that issue.

    We are all up to date with CC.

  • Joe Wood

    August 10, 2023 at 1:12 pm

    Attached is one ai file that artboard is 1920×1080 but when you import as a composition it comes in at 192×108. I received this file (there were more artboards I removed for privacy) from client, so can not speak to how it was setup.

    Also, I was incorrect yesterday. That workaround does work. If you copy and paste the vector layers to a new Ai file and then import that into After Effects, it will work. Just make sure you have “Paste Remembers Layers” turned on if you want it to retain the layer names.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy