Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro How to keep external audio track from moving when synchronizing with multiple video tracks?

  • How to keep external audio track from moving when synchronizing with multiple video tracks?

  • Ilya Blokh

    December 7, 2014 at 2:09 pm

    I am trying to edit a video that has external audio from an H4N recorder and internal audio from 2 Canon DSLRs. The internal audio is just there to help my sync everything and will be muted during output.

    From the H4N I have one long, continuous recording, but from the cameras I have shorter clips, not all of which happened exactly after the previous one.

    Here’s the issue I’m having: when I sync the two video clips & the external audio early in the timeline, everything lines up. However, when I am syncing clips later in the timeline, sometimes Premiere chooses to pull the external audio track FORWARD (thus bringing it out of alignment with the earlier video), rather than pushing the video tracks BACK (which is what I need).

    Is there some way to tell Premiere which tracks should and should not be moved during sync? If I lock the track, then I cannot use the sync function on it at all.

    Thanks!

  • Carson Gale

    December 11, 2014 at 6:16 am

    Alright (this is an edited post)

    1. I see what you’re doing, and have explored the function. I didn’t even know that existed in premiere pro! So that was interesting.
    2. The way you’re working through your project, maybe this won’t work for you. But the way I would approach this is one of two ways.

    a) Bring in two layers. Identical copies of the continuous audio. Bring in your media, and sync it with the ‘sync’ track (one of the full length audio clips). Then group those files (The new clip you brought in, plus the audio) and manually align the two full length audio clips. Now un group, and your new clip is synced with BOTH the sync and stationary audio track, regardless if it pulled the audio forward, or pulled the video forward.
    b) It seems to work that it always brings clips forward in time to sync them, and never pushes clips backwards, this is probably because you could run into problems trying to push media into negative space. Imagine if you have a clip that syncs at 1 minute in, and you bring both clips in and start them at 0, now premiere wants to move the audio you have into negative one minute on the timeline. This obviously isn’t plausible.
    So, just bring your clip in on a new layer, at the beginning of the timeline, where it will definitely be the clip to be moved forward, select it and the audio layer, and let it bring your new clip forward in time until it’s synced. Next clip the ends of the media as needed and drop it into the layer you need it in.

  • Ilya Blokh

    December 12, 2014 at 3:18 am

    Hi Carson – thanks so much for taking a look into this. That sounds like a great approach, will try it next time I’m doing this.

    It does seem like something Premier should address though – a simple setting that tells it to use a specific track as an “anchor” would do the trick I think (and perhaps it would throw a warning if the clip was going to move into negative space).

  • Thomas Alberti

    April 28, 2015 at 7:47 pm

    So is the feature totally absent?

  • Lalven Sanga

    January 15, 2016 at 3:16 pm

    I was having the same trouble. Thanks Ilya for posting about it. Premier needs to address the issue

  • Jason Conrad

    February 2, 2017 at 5:49 pm

    “It seems to work that it always brings clips forward in time to sync them”

    -This answered the question for me. Thanks.

  • Paul Judd

    May 12, 2017 at 11:23 pm

    Hi, everyone!

    It was annoying issue for me for years and finally i’ve got it fixed!

    Now if you wanna synchronize one track with another using the last as an “anchor” just put the new one on timeline before or even at the very beginning of the existing clip and use the sync option as usual. Pemiere will move the new one instead of the old one.

    Cheers

  • Craig Giffen

    January 18, 2019 at 6:12 am

    Thank you!

    This is kind of an esoteric/counterintuitive fix, but hey it works! I just shoved everything on the timeline over to the right a bit. Then one by one, I drag the clip to the start, then sync with my audio track…and it puts the video track in the right spot. Repeat.

    Thanks again. This has bugged me for awhile now.

  • Kevin Perkins

    August 12, 2022 at 9:50 pm

    it’s insane that even years later this is still an issue, but first of all, thank you so much for the (100% accurate) response!

    Putting the new vid to be synchronized at the beginning of the timeline does the trick. It’s amazing that by linking previously imported clips to the master timeline makes sync unavailable for any new vid/audio to be synchronized.

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy