Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D How tavoid TRESPASSING particles in deflectors ?

  • How tavoid TRESPASSING particles in deflectors ?

    Posted by Mauricio Barrientos on September 6, 2023 at 3:46 pm

    explanation:
    I have a particle emitter [[cubes]] but they go through the DEFLECTORS if they move facing them.
    How I can avoid this ?

    I leave here a video showing the problem, and it has sound.
    I will appreciate any comment, thank you very much.

    video:

    https://youtu.be/y-RsmCwGdBM

    Some contents or functionalities here are not available due to your cookie preferences!

    This happens because the functionality/content marked as “Google Youtube” uses cookies that you choosed to keep disabled. In order to view this content or use this functionality, please enable cookies: click here to open your cookie preferences.

    Brie Clayton replied 10 months, 2 weeks ago 4 Members · 8 Replies
  • 8 Replies
  • George Charoupas

    September 6, 2023 at 7:19 pm

    Hello Mauricio,

    When you move the deflectors, there is a a frame where the moving deflector gets past the cube and so the cube can not be deflected any more.

    The easy way to counter it is to put a destructor behind the deflector, so the cubes that gets past the deflector gets destroyed.

    Another way to achieve the same result is to replace the deflector with a plane or a very thin cube and put a collider body tag on it. On the cubes put a rigid body tag and increase the bounce to 100% on both tags. You can increase the substeps and iterations to fine tune your result. This method should work fine, but the cubes will also interact with each other and it’s also needs more resources from your computer.

  • Mauricio Barrientos

    September 6, 2023 at 8:22 pm

    no .. its ok ….. i have a great computer.

    my problem is i dont knwo how to config rigid body on a cube.

    please, sorry, can su send a picture of config please.

    i got the idea, but not work yet.

    coz , when i put a rigid body … fall to ground, and not work.

    i will aprciate your help please.

    thanks

  • George Charoupas

    September 7, 2023 at 9:17 am
  • Kouraib Abdmalek

    September 7, 2023 at 9:22 am

    Hi Mauricio,

    maybe the problem is in the deflector setting, please make sure that you disable the “split beam” to avoid trespassing like in the screenshots below

    thanks

  • George Charoupas

    September 7, 2023 at 11:13 am

    Hi Kouraib,

    Even if the split beam is disabled, cubes are going thru the deflector.

  • Mauricio Barrientos

    September 7, 2023 at 11:48 am

    hi ….thanks i apreciate that but not work. sorry

  • Mauricio Barrientos

    September 7, 2023 at 11:50 am

    Thank you definitely!!!!

    This is what I’m looking for, video number ONE.

    since in the second, some are lost when destroyed.

    once again thank you, I appreciate your time for recording those videos.

    I am indebted to you, thank you.

  • Brie Clayton

    September 7, 2023 at 2:02 pm

    Thank you for the solve, George!

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy