Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro How do I move the sequence file outside of a folder without losing the project?

  • How do I move the sequence file outside of a folder without losing the project?

  • Paul Nicholson

    October 2, 2019 at 7:21 pm

    This is an extremely hard problem to solve using Google. I have spent ten hours searching so far. My project’s images consist entirely of scrolling photoshop layers that reveal lyrics in time with the backing track audio. I have been using a text editor to try to hack the pproj file but its complicated and my coding skills aren’t good enough.

    The problem is simply this: Adobe Media Encoder is showing me that it is running through every single of the 470 items in the project just to export a single 4 minute song (4 photoshop image layers and an mp3 or wav).

    I always select the work area correctly and the exported video is always perfect. Its the wasted time I want to fix. I suspect Premiere is doing all this because everything is inside one ‘bin’ (folder). All new photoshop layers land in their own sub-bins but the 300+ items that existed before the timeline import trick are floating around in the one bin – mostly with the same name ‘black rectangle’ – I use black rectangles for revealing lyrics from a dark opacity shield and under the titles. Also, as you can imagine, I named the chord images for each song “chords”, so there are a lot of items called “chords”. The project has no problem distinguishing between all these same named items at all. I dont intend to start again – its been around five hundred hours work so far and it could barely have been achieved any faster.

    The photoshop images are simply text, black rectangles and occasional tricky chord icons. They caused no issues in export speed before the timeline import trick caused premiere/adobe media encoder to run through every single item in the project for little four minute, four file exports in a dedicated work area.

    Dragging every file out of the bin and into the root pops up the warning:

    ………

    Wait a second!

    ………

    Instead of pressing Ctrl X on all the items in the bin, this time I DRAGGED them out. Strange how Premiere considers cutting and pasting different from dragging – thats like Apple logic. This didn’t cause any harm for a change ☺ Now I just deleted the empty bin and yes! ☺ They are all now in the root!! The project still seems completely intact! ☺

    Now to run a test….

    Ouch. It seems that my ‘bin’ theory was wrong. Thank Zeus its eliminated, though. Now I can move on to finding the ACTUAL reason Adobe Media Encoder is processing every file in the entire project.

    I have been watching Adobe Media Encoder’s Encoding panel and I am seeing all the audio files, both mp3 and wav being processed all together with no other file types mixed in. The order is suspicious – it is not alphabetical. Upon inspection it is in the order from left to right of every song in my sequence. Yes, it appears to have gone through every audio file only from left to right through the sequence. No other files (images) were mentioned in the Encoding window. During this time, the elapsed and remaining times remained frozen and the progress bar had not begun, but after the audio files had ‘processed’, the project encoded at full speed. I don’t know what is causing this.

    I’m going to close Premiere and reopen it and see if the project is still intact, and close and reopen Adobe Media Encoder and see if this happens again. It could be related to my export settings maybe?

    I am rendering the work area (enter key) and this time I’ll export with ‘Use Previews’ selected…

    Oops. Adobe Media Encoder froze – I had to close it with Task Manager. Just a sec…

    I exported with ‘Use Previews’ and it made no difference. One last thing I can think to try – clear all cache for Premiere – there could be conflicts caused by the import timeline trick…

    Edit>Preferences>Media>Media Cache Database. Clean.

    Exporting…

    Wow. This is taking forever. Maybe it needs to completely rebuild everything. Fingers crossed. I also enabled Project>Project Settings>General>Video Rendering and Playback: GPU acceleration – my timeline is yellow now. Hopefully thats a good thing.

    Ok, I wasnt watching that time, but the export worked successfully after half an hour. Let me try again – maybe everything’s fixed now…

    Adobe Media Encoder’s Encoding panel is stuck on “Reading XMP…” Elapsed 00:00:01 Remaining _:_:_

    5 mins like this so far. Computer whirring.
    7 mins.
    9 mins…wait.
    It stopped saying “Reading XMP…” and then Remaining changed to 00:00:26 and the video was exported within 20 seconds.
    Great! Making progress! ☺

    Now I just have to figure out how to make every project export within 20 seconds like that, without the 9 minutes of reading XMP.

    I turned off GPU acceleration and cleaned the cache again to see if it would help, and now its gone back to processing every audio file in the project. Huh???

    Im now going to uncheck Edit>Preferences>Media>”Enable Clip and XMP Metadata linking”
    Exporting…

    That did nothing.
    Now I’ll reactivate GPU acceleration AND uncheck “Enable Clip and XMP Metadata linking” AND Clean Cache AND restart Premiere AND restart Adobe Media Encoder…

    Adobe Media Encoder always needs to be restarted with Task Manager if I cancel an export.
    Ok.
    Now time for an export test.

    Here are the properties for the lyrics text file for this export:

    File Path: D:\Pictures\Backing The sound of silence.psd
    Type: Photoshop
    File Size: 3.3 MB
    Image Size: 1536 x 5234
    Pixel Aspect Ratio: 1.0

    Exporting with these settings:
    Output
    H.264 768×1024, 30fps, Progressive CBR, Target 2.00 Mbps AAc, 160 kbps, 48 kHz, Stereo
    Source
    Sequence, Backing Tracks 1536×2048 (1.0), 30 fps, Lower, 23:58:56:02 48000 Hz, Stereo

    Profile Main Level 4.0
    Render at Maximum Depth – unchecked
    Key Frame Distance – unchecked
    Use Maximum Render Quality – checked
    Use Previews – checked
    Use Frame Blending – unchecked.

    Estimated file size for this 3 minute iPad video is 46 MB.

    Any confusion about these settings would be related to the iPad 4 being upgraded to the iPad 6 – vastly different video allowances.

    Here goes. Exporting with the QUEUE button in Premiere Pro CS6:
    Adobe Media Encoder opened and ready. Play.
    Its 5:06am. Reading XMP…
    5:11am. Reading XMP…
    5:12am I have added an extra 4 minute video to the export queue to test if Reading XMP only has to happen once.
    5:14am. Reading XMP…

    5:15am. Started progress bar. Completed within 20 seconds.
    Next video in queue has started. Reading XMP…
    5:18am. Cancelling export. Using Task Manager to shut down Adobe Media Encoder. Deleting incomplete files from all the testing.
    Re-checking Edit>Preferences>Media>”Enable Clip and XMP Metadata linking” because disabling it had no effect. Leaving GPU acceleration active.

    Any ideas on how to speed up ‘Reading XMP…’ encoding? It seems like three minutes of reading xmp per 1 minute of video. Thankfully I’m not seeing the audio files being processed now that GPU acceleration is active – but they might simply be hidden in this mode.

    Any ideas?

  • Greg Janza

    October 2, 2019 at 7:40 pm

    can you do two things?

    1. take a screen shot of your Premiere timeline.

    2. post up one of these videos that you’re creating.

    Your project is very unique and niche. It’s almost impossible to envision what it is that you’re actually doing.

    https://www.linkedin.com/in/tmprods
    tallmanproductions.net

  • Paul Nicholson

    October 2, 2019 at 9:16 pm

    https://community.adobe.com/t5/Media-Encoder/AME-CS5-5-hangs-on-quot-Reading-XMP-quot/m-p/3571243#M356

    In this thread, I read this:

    achilleasd44460517
    Nov 11, 2016

    I think the problem’s solved!

    This took dozens of exports and deleting rendered files and trying to figure it out and i think i got it nailed!

    It has to do with forcing AME to render audio!

    This happens if you’ve made a change in audio in your timeline and did not render it before exporting.

    (I have the option to render audio after video disabled for ease of use)

    FIX : Last step before exporting : “Render Audio” and whatever you do DO NOT cancel it.

    Once canceled it freezes if you try rendering it again and may even crash Premiere.

    I suspect it passes a completed file to AME if you allow it to complete without interrupting

    otherwise AME is forced to render audio itself

    (maybe what we call “hang” is actually a background audio render attempt by AME that takes bloody ages or fails completely!)

    Setup :

    Adobe Premiere CS6 and AME CS6

    tried on both AMD AND INTEL setups

    I have been clicking audio gain normalize peaks to zero on every song with very bad results. It seems like AME needs to encode audio if its not rendered by Premiere before an export. This is stupid given that none of those audio files are within the work area, but rest assured, its Adobe’s fault. Normalizing audio gain peaks to zero decibels makes some songs max out at -20 decibels and others exceed 0. Its clumsy and broken code. I might have to redo all the audio levels from scratch if its leading to all this trouble with no benefit.

  • Greg Janza

    October 2, 2019 at 9:51 pm

    An easy way to determine if you’re audio is triggering the problem is to bounce your timeline audio to audition and then bring a stereo mix back into Premiere.

    https://www.linkedin.com/in/tmprods
    tallmanproductions.net

  • Paul Nicholson

    October 2, 2019 at 9:53 pm

    Okay, so further reading has shown me that Adobe Media Encoder CS6 is awful and doesnt work properly.

    The settings you should have is GPU acceleration. Maximum Render Quality. Export NOT Queue.

    And I just checked Edit>Preferences>General: ‘Render audio when rendering video’. Then I pressed Enter. Now its rendering my audio. I will see if I can get a fast export now…

    YAAAAAAAAYYYYYYYYYY!!!!!!!!!!!

    30 second export for every song!!!!! Im back baby! Perfect Quality ☺ ☺

  • Greg Janza

    October 2, 2019 at 9:58 pm

    Your next order of business to upgrade your Adobe to Adobe cc. You’re using ancient software.

    https://www.linkedin.com/in/tmprods
    tallmanproductions.net

  • Paul Nicholson

    October 2, 2019 at 10:27 pm

    Whats the benefit? Dont you have to keep paying money forever or something weird?

  • Greg Janza

    October 3, 2019 at 3:22 pm

    Are you a professional editor or hobbyist? If you’re a professional, you owe it to your clients to be up to date on the software.

    https://www.linkedin.com/in/tmprods
    tallmanproductions.net

  • Paul Nicholson

    October 4, 2019 at 9:39 am

    My only clients are me, myself and I. I hope my experiments taught you some things. You appear to want to remain the authority but I had to solve it all myself. You didnt react to my industriousness, only gave more advice. I hope others can find my work useful.

Viewing 11 - 19 of 19 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy