Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Illustrator How can I remove a stroke, keeping distance the same?

  • How can I remove a stroke, keeping distance the same?

  • Samantha Lasbury

    June 12, 2010 at 2:21 pm

    I have an object made up of lots of tiny squares. The squares are coloured and the outline is white so that the squares remain the desired distance apart. This works well on a white background but I’d like to be able to put on any colour background without having to change the stroke colour each time.

    I have tried to use ‘object – path – outline stroke’ then delete the outline, however this just brings my squares closer together, rather than keeping the desired distance.

    I am also having trouble with the same oject, in that when I shrink it and enlarge it the distance between the squares does not seem to remain to scale. It’s driving me crazy! Any advice would be massively appreciated!! 🙂

  • Vincent Rosati

    June 12, 2010 at 4:07 pm

    I’m sure there are a bunch of different approaches you could take to this.

    Create a new layer.
    Draw a box that is the correct size.
    Ctrl+Drag the object with snapping enabled to duplicate the object at the correct distance.
    Then Ctrl+D to repeat the Duplicate operation. This will create one row.
    Now you can group the row of boxes and perform the same function to fill the remaining area.

    An example of Ctrl+D is here… @time 1:40.

    If you already have the new boxes drawn you could also use the Window/Align tool to evenly space everything.

    Select all of the squares, then Object/Path/Outline Stroke.
    Select All and Ungroup (as many times as necessary).
    Select the ‘path’ and Select/Same/Fill Color and Pathfinder/Add to combine all of the ‘strokes’ into one object.
    Select a fill and Select/Same/Fill Color then Object/Compound Path/Make to combine all of the fills into one object.
    Select the fill and Object/Arrange/Bring To Front so the fill is on top of the ‘strokes’.
    Now select everything and Pathfinder/Minus Back.

    “does not seem to remain to scale”
    Edit/Preferences/General/Scale Strokes & Effects.

    Just some ideas.


    *Please remember to Rate our replies or check Solution if solved. If you get a good idea from the post, consider clicking the Kudos option.

Viewing 1 - 2 of 2 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy