Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Blackmagic Design HELP! Horrible Blackmagic 10-bit uncompressed renders from Apple Shake or FCP

  • HELP! Horrible Blackmagic 10-bit uncompressed renders from Apple Shake or FCP

  • Michael Buday

    February 15, 2007 at 7:20 pm

    I’m working on one hour’s worth of cinematics for an upcoming game that was shot entirely bluescreen (Digibeta aquisition–>Blackmagic 10 bit SDI ingest to FCP). The material imported into FCP looks great, as it does when composited in Shake with all the CGI material, HOWEVER – when I render BACK to the same uncompressed Blackmagic codec, everything falls apart in terms of bit-depth. All the gradients in any blurs or defocus nodes look terrible with significant banding.

    If I render out to Apple Animation or Blackmagic 10-bit RGB, everything looks great, but I don’t know if I can edit in FCP using either of these formats, plus – I ultimately have to get back to a format the game engine guys can use when all is completed – which is an uncompressed AVI file.

    Anyone else seen this terrible performance when rendering out to Blackmagic 10-bit uncompressed NTSC? Any work arounds?

    I need HELP real fast as my delivery date is FAST approaching.

    Many thanks,

    Michael Buday

  • Kristian Lam

    February 15, 2007 at 11:02 pm

    Hi Michael,

    The Blackmagic codecs (other than 8-bit (2vuy) and 10-bit RGB) are not available in Shake or FCP, only the Apple Uncompressed 4:2:2 codecs are. Can you verify which codec you’ve used?

    What version of our drivers do you have installed?

    Are you on a G5 or Intel Mac Pro?

    What version is Shake?

    As a test, try uninstalling our drivers using the “Uninstall Blackmagic” application located with every driver download, do the renders again and see if that makes a difference.

    regards

    Kristian Lam
    Blackmagic Design

  • George

    February 16, 2007 at 2:19 am

    I had the same problem. Removing the black magic codec from the /library/quicktime folder where all the QT codecs solves the issue if you have it there.

    using the native Apple Compressed Coded thereafter..

  • Michael Buday

    February 16, 2007 at 6:31 am

    Hello Kristian and thanks for your quick response:

    >> The Blackmagic codecs (other than 8-bit (2vuy) and 10-bit RGB) are not available in Shake or FCP, only the Apple Uncompressed 4:2:2 codecs are. Can you verify which codec you’ve used? << Well, it says "Uncompressed 10-Bit 4:2:2" in the Shake/FCP options during export, but when I open the file in QT player and look at it's properties, it reports "Blackmagic 10-Bit". >> What version of our drivers do you have installed? << The very latest since a couple of days ago. >> Are you on a G5 or Intel Mac Pro? << Mac Pro >> What version is Shake? << v4.10.0606 I'll try uninstalling the drivers as you recommend, but FYI I digitized all the uprezzed footage via the Decklink card as uncompressed 10-bit 4:22, so if I uninstall the QT drivers, will I still be able to play this media? Thanks again, Michael Buday

  • Michael Buday

    February 16, 2007 at 6:31 am

    I’ll give that a go George. Many thanks for your help, and I’ll let you know if that works.

    Michael Buday

  • Michael Buday

    February 16, 2007 at 7:04 am

    OK, I tried uninstalling the Blackmagic drivers (I did this manually because I needed to re-download the installer to uninstall the drivers, but the Declink site was down).

    Anyway, I removed the drivers from the Library\QuickTime folder and verified that they no longer appeared as an option withing QT, but the problem is still there. It’s almost as if it’s outputting to an 8-bit or less bit depth. As I mentioned before, rendering out to RGB or BMP or other uncompressed formats looks great.

    So I apologise if this isn’t a Blackmagic issue, but what else could it be?

    Michael

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy