Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Premiere Pro GPU’s not being used by Premier pro when rendering

  • GPU’s not being used by Premier pro when rendering

    Posted by Tuscan Gilder on February 2, 2024 at 2:42 pm

    Context – Before this problem, when I rendered “in to out” and looked in my task manager, it would show that both my Nvidia GPU and Intel GPU were being used to render the sequence (often peaking at 100%). This was extremely fast rendering compared to what I’ve had on previous machines. Here is a screenshot of what that looked like.

    *See screenshot 1

     

    The below are the settings of before there were any problems/changes.

    *See screenshot 2

     

    I opened up PP a few days ago and felt that the render speed was much slower than it normally was and discovered that now the CPU and the Intel GPU were being used to render (the Nvidia GPU was at 0%) the speeds of rendering in these conditions are very noticeably slower. The below screenshot shows what the task manager looks like now when doing the same thing with same settings.

    *See screenshot 3

     

    When I change to these settings (below) the task manager looks like this (also below).

    *See screenshot 4

    *See screenshot 5

     

    It might be worth mentioning that these “symptoms” are present on two identical laptops.

     

    Essentially, I want to get back to where both GPU’s are being used as seen in screenshot 1.

     

    I contacted adobe support who went through the usual troubleshooting things and below are the steps taken to try to fix this issue – none of them worked –

    – It is not project/media based – this problem happens on all projects and all types of media I’ve tried.

    – Restarting the laptop

    – Removing PP and reinstalling it

    – Reinstalling the Nvidia graphics driver

    – Allowing all the permissions for PP

    – Rolling back to a previous windows version

    – Yes, I’m using CUDA!!

     

    Here are the details/specs of my machine:

    – Windows 11 Pro – 10.0.22631 Build 22631

    – System manufacturer – Dell

    – Model – XPS 15 9530

    – RAM – 32

    – GPU0 – Intel® Iris® Xe Graphics

    – GPU1 – NVIDIA GeForce RTX 4070 Laptop GPU

    – Processor – 13th Gen Intel Core i9-13900H, 2600 Mhz, 14 Core(s), 20 Logical Processors

    – Premier pro version – 24.1

    – We have a Qnap NAS which we use for all media storage, and where we edit off.

    This is a really frustrating problem, as we have invested considerable amounts of money into hardware and it’s not at all being used optimally.

    Please let me know if you need any other info or context.

    Tuscan Gilder replied 5 months, 2 weeks ago 2 Members · 5 Replies
  • 5 Replies
  • Rob Ainscough

    February 2, 2024 at 5:47 pm

    Intel Iris Xe Graphics does NOT support CUDA so don’t really know how you managed to use it?

  • Tuscan Gilder

    February 5, 2024 at 8:21 am

    Thanks for your reply,

    This is more helpful than you think!

    I thought that using CUDA and having both the Intel and Nvidia GPUs working at the same time was normal as that’s what happened “out of the box”. But its now clear it was glitched.

    Now, when using the settings as seen in Screenshot 2, neither of the GPU’s work, any ideas how to get my Nvidia drive working again. As mentioned above I’ve done everything short of physically removing and putting it back into the laptop.

    Be very glad of anyone’s help.

  • Tuscan Gilder

    February 5, 2024 at 11:52 am

    To update – i have resolved this issue, but am very sure that premier pro has a bug specifically relating to changing (ticking/unticking) GPUs in the (preferences->media) settings.

    I have come to this conclusion because – i spoke to Nvidia who told me to remove the driver with there clean-up tool, and do a clean install of the driver. After doing so i then tested and all was back to normal (with my settings as seen in screenshot 2). i then changed the settings here to include the intel gpu. It then didn’t work. So i went back to just having Nvidia ticked, and still nothing!!!

    After completing the removal and reinstallation process for a second time, i haven’t changed the settings and all is working fine.

    I’m hoping no-one else has this problem, and therefore don’t read this!!!!

  • Rob Ainscough

    February 5, 2024 at 5:09 pm

    When you say “all is working fine” … I’m assuming just the nVidia GPU for rendering using CUDA (no Intel embedded)?

    Handy tool for cleaning nVidia drivers is call DDU

    1. Download latest nVidia “studio” drivers (not GRD)

    2. Download DDU (unzip and extract)

    3. Boot PC into safe mode (msconfig and check Safe mode)

    4. When loaded in safe mode run msconfig again and uncheck safe mode)

    5. In Safe Mode: Disconnect your internet connection (disable wireless and/or network)

    6. In Safe Mode: Run DDU (select GPU and hit Clean and Restart)

    7. Reboot (still stay disconnected from Internet)

    8. Manually install the nVidia Studio drivers from step 1

    9. Once complete reboot

    10. Re-enabled your network

    DDU you can get here (trusted):

    https://www.guru3d.com/download/display-driver-uninstaller-download/

  • Tuscan Gilder

    February 6, 2024 at 4:31 pm

    Correct, it is now just Nvidia being used when rendering and CUDA is selected (there is no intel embedded).

    Thanks for that information – very useful.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy