Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D Getting rid of frayed and jagged edges in 3D animation

  • Getting rid of frayed and jagged edges in 3D animation

    Posted by Sam Beesems on November 15, 2012 at 3:42 pm

    Hey guys,

    I’m currently working on a job for a Dutch customer, and I’m having some problems rendering out as you can see in these images:

    Picture viewer in C4D
    https://tinypic.com/r/15xlnv5/6

    Final render in VLC (quicktime, animation setting, 720p)
    https://tinypic.com/r/e7i39e/6

    This is my first project in C4D, but I’ll try and provide some background info. I imported the logo from Illustrator, created NURBS from the outlines, turned these into polygons and animated a camera around it.

    I could upload the clip itself, but I thought the images might already give some of you an idea as to what I’m doing wrong. Any thoughts on how I can smooth these edges and get rid of the jagged sections and the weird noise around it?

    Thanks in advance!

    Sam

    Darby Edelen replied 11 years, 3 months ago 5 Members · 7 Replies
  • 7 Replies
  • Alex Shackleton

    November 15, 2012 at 4:02 pm

    hi dude

    try this, go to your render settings and in the anit aliasing tab change it from geometry to best.

    That should do it.

  • Sam Beesems

    November 15, 2012 at 4:04 pm

    Did that already, now pumping out a render with a min of 8×8 and a max of 16×16 in the anti-aliasing settings. Could it have something to do with the alpha channel?

  • Alex Shackleton

    November 15, 2012 at 4:17 pm

    i looked at the images again and it looks really odd, just the standard settings from cinema should produce those fuzzy lines… the only thing I can think of is the spline path.

    try making a rectange spline in cinema and extruding it, and rendering with the same settings and see if you get the same results.

  • Jeremy Allen

    November 15, 2012 at 8:37 pm

    Most likely the alpha channel.. Are you going to composite this logo onto other footage? I wouldn’t worry too much about the edges until you do that. Then see if you still notice the edges. Sometimes the player (VLC, quicktime, etc) will show weird edges around alpha channels, especially depending on the type of alpha (straight vs. pre-multiplied).

    8x8min and 16×16 max seems like waaayy overkill to me for something like this. From what I understand about C4D rendering, your basic geometry setting or even 2×2,4×4 should provide acceptable results for this logo.

    ———————————————
    8core MacPro, 3.0 GHZ, 18GB RAM, OSX 10.5.8

    C4D 12
    AE CS5 (10.0.2.4)
    FCP 7.0.3
    QT 7.6.4

  • Florin Cosmin

    November 17, 2012 at 8:12 pm

    export the images as tiff in Photoshop and then save them as JPEG…

  • Sam Beesems

    November 17, 2012 at 8:15 pm

    First and foremost, thanks for helping out! Secondly, I figured it out. It has to come down to one of these two things: I changed an export setting from cubic image to Gauss (animation) and decided to check off straight alpha channel. And now, it works! I’ve got some incredibly crisp 3D footage to boot.

    So, once again: thanks for the help, and consider my question answered!

    Sam

  • Darby Edelen

    November 20, 2012 at 3:30 pm

    [Sam Beesems] “check off straight alpha channel.”

    This was your problem.

    Darby Edelen

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy