Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects Get out of shape tool mode and back to mask mode

  • Get out of shape tool mode and back to mask mode

  • David Sandwisch

    April 8, 2011 at 10:20 am

    Hi Everyone,

    I want to simply create a mask on a layer using the pen tool to draw it. I have done this many many times without a problem. For some reason when I click on the composition window with the pen tool, AE thinks I want to create a shape and creates a new layer called a shape layer. I don’t remember doing anything to tell it I wanted to be in the shape tool mode.

    How do I get out of this mode and back to drawing simple masks with the pen tool? I’ve already tried to click the “tool creates mask” button but it’s always grayed out. I’m on CS 5 on a Mac.

    I’m perplexed as to how I got stuck in this mode and my brain may not be working too well after many hours of not stop editing. Any thoughts?

    Thanks,
    David

  • Roland R. Kahlenberg

    April 8, 2011 at 10:48 am

    If no layer is selected and one of the mask tools is in use and you click on the Comp area, a Shape Layer will be created. To draw masks, ensure that a layer is first selected.

    HTH
    RoRK

    AE Training in South East Asia. AE templates for sale and rental. Click here for more

  • David Sandwisch

    April 8, 2011 at 11:05 am

    Thank you for your response. I understand a layer must be selected and that is what I have been doing. I have a layer selected, the pen tool selected and then clicking in the comp area creates a shape layer with purple dots / lines instead of a mask with yellow dots / lines like it usually does.

    I have never used shape layers before and I have no idea how I entered into this mode or how to get out of it. I googled a bit and tried to turn the “tool creates mask” button on but it’s always grayed out.

    Thanks in advance for more ideas!
    David

  • Roland R. Kahlenberg

    April 8, 2011 at 3:41 pm

    Mask colors default to the last color that was set/used unless you turned on Cycle Mask Colors in the Prefs dialog window.

    THe “tool creates mask” button in activated when a Shape Layer is active AND one of the Shape Tools is selected.

    It sounds like you do not have a shape layer activated. I suggest you double and tripple check what you actually have. If you’re really confident of the scene and feel that it’s not a user-error then try trashing your prefs.

    HTH
    RoRK

    AE Training in South East Asia. AE templates for sale and rental. Click here for more

  • Lee Chabowski

    December 11, 2015 at 5:13 pm

    I realize this is an ancient thread, but for anyone who’s experiencing the same issue, take a look at this before you ditch your preferences, or some other extreme measure. I was pulling my hair out trying to figure out why suddenly my pen tool would only create a shape and not a mask, when I had used it successfully a million times before. I finally realized that I had shortened the length of my layer so that it wouldn’t be visible until a certain point on the timeline. The layer underneath contained the same image, so I didn’t realize that my playhead was sitting earlier in the timeline than the point where my active layer came in. So the tool didn’t recognize that there was a layer to add a mask to. When I finally realized that the playhead needed to be moved, I moved it to where my active layer was visible, and then the pen tool successfully created a mask. Whew!

  • Sally Vale

    March 7, 2016 at 7:09 pm

    OH MY GOSH thank you, I was going crazy trying to figure out what I’d done! That was exactly it.

  • Peter Berdovsky

    September 13, 2016 at 3:01 pm

    Thanks so much! That was exactly my problem. I thought I was going nuts 🙂

  • John Lewis

    June 27, 2019 at 12:25 pm

    Lee that was a really useful tip. I was having this same problem and I’d thought it was linked to CC as I have recently upgraded. It was just the playhead being in the wrong place. I cant believe I’d never had this issue before! Thanks a million for posting this.

  • Josh Snider

    January 17, 2021 at 2:19 pm

    THANK YOU!!!!!!!! 10 years after the original post. So glad you left that comment!!

Viewing 1 - 9 of 9 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy