Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Maxon Cinema 4D Geometry Antialiasing Issues

  • Geometry Antialiasing Issues

    Posted by Mark Walczak on December 7, 2010 at 2:05 am

    Hi Everyone,

    I’ve run into something in Cinema that’s really got me stumped. I’m working with a model of a phone that I downloaded from Turbo Squid that is giving me terrible aliasing issues. Even when rendered with minimum and maximum levels both set to 16×16 (I know that’s insane), I’m still getting crunchy/choppy serrations around seams and in reflections. I’ve done everything including the following:

    – Made sure that my object is only reflecting the sky
    – Made sure I didn’t have any aliasing artifacts in the HDRI feeding my sky object
    – Experimented with different filters, including Blend with Softness set as high as 65%
    – Removing all specularity from materials
    – Experimenting with different render resolutions (1920×1080 is giving me the best result)
    – Experimenting with the AA overrides in Compositing tags
    – Experimented with different levels of HyperNurb subdivision

    Again, this is a strange problem because it only manifests itself on geometry edges. All reflections on broad surfaces and bitmapped textures are all rendering silky smooth. I’ve never seen this as a problem before, and was wondering if perhaps it was related to the most current update to Cinema (although I doubt it).

    Any thoughts/comments would be greatly appreciated!

    Thank you,

    Mark Walczak replied 13 years, 5 months ago 3 Members · 6 Replies
  • 6 Replies
  • Adam Trachtenberg

    December 7, 2010 at 4:08 am

    My guess is that the object either doesn’t have a phong tag, or if it does, the smoothing angle is too low.

  • Mark Walczak

    December 7, 2010 at 2:39 pm

    Hi Adam,

    Thanks for the tip, and I’ll be sure to start experimenting with the phong tags in a moment. I wanted to post some screengrabs of the issue, though, to provide more clarity about my issue. They are attached below and were done with the following settings:

    Anti-Aliasing: Best
    Filter: Blend
    Softness: 65%
    Threshold: 10%
    Min Level: 4×4
    Max Level: 4×4
    Use Object Properties: Deselected
    Consider Multi-Passes: Deselected
    MIP Scale: 50%
    Small Fragments: Hybrid

    As you can see from the photos, the issue is really manifesting itself around the screen and around the phone itself. It should be noted that I am not rendering an alpha channel, as I know rendering with a straight alpha sometimes appears to look ugly around the edges when viewed in some programs that do not display an alpha channel in-viewer.

    Again, thank you for all of your help. I’ve never had this problem before, and I hate wasting so much time trying to refine something that isn’t usually an issue.

    Just for the sake of clarity, I am running Cinema R12 on OSX 10.6 installed on an 8-core Mac Pro.

    Thanks again!

    https://goo.gl/TN433

    https://goo.gl/yFxYC

    https://goo.gl/5EYGB

    https://vimeo.com/explosivegraffix

  • Adam Trachtenberg

    December 7, 2010 at 3:27 pm

    Ah, okay, definitely not a phong problem. I would try lowering the thresshold to 3% or less.

  • Mark Walczak

    December 7, 2010 at 4:28 pm

    Hi Adam,

    Thanks for your response and I apologize for not replying sooner.

    I’ve dropped the threshold (even down to 0 at times), and am still getting the following result:

    https://goo.gl/ClN5z

    https://goo.gl/pyyIW

    https://vimeo.com/explosivegraffix

  • Jay Ingles

    December 7, 2010 at 9:25 pm

    I’ve been fighting this as well but am not very experienced with C4D. My resolution was to render it without reflections, then render out reflections separately.

    Under Anti Aliasing you can checked “consider multipass”. In the manual (show help) it loosely touches on the issue you’re having.

    As well, i’ve read that adding composite tags with “force AA” and a lower threshold on specific textures may help resolve situations while keeping render times down for other parts of the image.

    Not sure if this helps but interested in hearing your solution.
    thanks.

  • Mark Walczak

    December 9, 2010 at 3:14 pm

    Thanks, Jay!

    I actually ended up purchasing another model that didn’t give me these issues, but your tip is very handy – thanks for posting it!

    https://vimeo.com/explosivegraffix

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy