Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Final Cut Pro: “File Attribute Mismatch” When Reconnecting Offline Media

  • Final Cut Pro: “File Attribute Mismatch” When Reconnecting Offline Media

  • Michael Schmidt

    March 5, 2010 at 8:09 pm

    Please help.

    I am running Final Cut 5.0 on my MacBook with OS 10.4.11, using Quicktime v. 7.6.0. Processor: 2.16 GHz Intel Core 2 Duo. Memory: 1 GB 667 MHz DDR2 SDRAM.

    I have encountered a problem reconnecting offline files into my current FCP project, where the files I am trying to reconnect “do not match the attributes of the original.” This problem seems to be specific to audio media and occurred when I drug some of my original media from one external hard drive to another to consolidate space. This move was done outside of FCP, with the app closed, and done for both audio and video media. Again, the problem seems to be specific to audio media.

    When I try to re-open the project and reconnect the media I receive the standard error message, “Some files went offline.” But when I search and reconnect the media, once the media is located, I receive a second error message, titled “File Attribute Mismatch,” detailing the problem outlined above. Specifically, the error box tells me that the attributes of the “original” media and “new” media (please remember these are the exact same files) differ in the following ways:

    – Media Start and End
    – Rate

    At first, I thought this was simply a problem that had to do with my Audio/Video Settings. I am working in a DV NTSC 48 kHz sequence, but with a 24 fps frame rate. Media was original imported and edited within this work space and with these Audio/Video Settings selected. But since starting this project, I have also worked in Uncompressed 10 Bit, and the settings were changed to this preset when I first did the reconnect. I reasoned that this had something to do with the “Mismatch.” But even after changing my settings back to DV NTSC 48 kHz – 24, I continue to get a “Mismatch” error message.

    NOTE: When using the DV NTSC 48 kHz – 24 preset, I am no longer told that the Rate differs from the original files, only the Media Start and End. Still, I am weary of proceeding with a project that has known In and Out point problems.

    In short, even when I alter my Audio/Video Settings–to the original settings or to alternative settings–I still get an error message. I just want to put my soundtracks back the way they were. It’s frustrating.

    Has anyone else encountered such a problem? And can anyone tell me how to remedy this situation?

    Who knew consolidating your media to a larger drive could create such a fiasco?

    Thank you in advance for your kind help.

    Michael

  • Bryan Less

    March 5, 2010 at 10:28 pm

    Michael

    I recently posted a similar question on this board and I solved my problem. I’m currently running FCP 7 and I tried to reconnect a show I edited almost a year ago. I continued to get the same File Attribute Mismatch, Start and End that you are getting. My clips were off by more than 20 seconds in some cases. I have another system in my department that is running FCP 6. I brought the project in to FCP 6 and reconnected with no problem. Could you have edited your program in an earlier version of FCP or QuickTime?

    Bryan

  • Michael Schmidt

    March 6, 2010 at 3:55 am

    Hey Bryan,

    Thanks for the note. Much appreciated.

    Nope, I did not create the current project in an older version of FCP than I’m using now. Created in 5.0, opened in 5.0. So I don’t know what the problem is. Again, I simply transferred some of my media from one hard drive to another. When I went to reconnect I got the “Mismatch” problem.

    There is some good news, however. Since I posted this thread, I took some time to tool around a little. I saved a couple copies of the original project file and then reconnected the media to each copy using different Audio/Video Setting sequence presets.

    In my previous post, I mentioned that the DV NTSC 48 kHz – 24 fps preset resulted in fewer error messages than when I reconnected the media using Uncompressed 10 Bit. The sole error message using this 24 fps preset said that the “Media Start and End” differed from the original media. But when I actually went and compared the in and out points of several audio clips in this new project with my old (un-reconnected) project file, I found that they shared the same audio in and out points, at least in the timeline. This was not the case in the project where I reconnected the media using the Uncompressed 10 Bit sequence setting, where clips were trimmed and/or volume nodes had drifted way out of sync.

    In the latter example, the variance was anywhere from a few frames to a few seconds based on the length of the original clip. Some clips were a couple seconds (off a frame or two, or not at all). Some clips were a couple minutes (off 12 frames to a couple seconds).

    Back to the former example, the 24 fps example. Since these sound clips are are non-dialogue FX, music and tone, at this early stage it’s difficult to tell if things are exactly like they were before I made the hard drive swap. But I’m feeling pretty good. At first glance, the lengths of the effected clips appear dead-on correct, and listening through the tracks, it also sounds like the volume nodes are mixed properly, not thrown off like it obviously was with the Uncomp 10 Bit reconnect.

    Again, I should mention that the reason I’m bad mouthing Uncomp 10 Bit is not because I believe there is something inherently wrong with Uncomp 10 Bit. The reason I’m doing this is because the media for this project was imported when I was using the DV NTSC 48 kHz – 24 fps sequence setting, and the project was also cut with this sequence setting. The problem seemed to occur when I used the Uncomp 10 Bit setting for an alternative sequence within this project, which again is primarily a 24 fps project. Or I should say that the problem occurred when I changed this setting, then disconnected the media and tried to reconnect it.

    For some reason, I’ve found that you need to import your media with the exact settings for your sequence, or face the consequences, even if this media is uncaptured, stand-alone media files. What’s more, it also appears you have to reconnect those media files with the same settings.

    The thing that continues to puzzle me, though, is that even when I return to the original settings, and reconnect the media, and the media appears to fall into the exact same place as the original project file, I still get an error message that says the “Media Start and End” differs from the original. It makes me wonder what I’m missing. Is it something, or just a glitch? But for now I’m happy.

    My only theory is that I could have originally (and mistakenly) imported some of the audio files while using the Uncomp 10 Bit setting, then edited them in a 24 fps timeline. When I disconnected the media and reconnected using the DV NTSC 48 kHz – 24 fps setting, FCP could have recognized the media as being “mismatched” (i.e. 29.97 frame, instead of 24) but still the same length in the 24 fps timeline. But this theory doesn’t really explain why the media would change so drastically in length (in and out points) when reconnected using the Uncomp 10 Bit sequence preset. In fact, one might think if I did happen to use this preset originally, this would be the one to use again, to remain consistent. I don’t know.

    I have taken this one step further as well. I have quit out of the new properly functioning project, disconnected the media and reconnected again. Seems to work perfectly well. No error message. No problems. Go figure.

    Please, if anyone has an explanation for this, add your thoughts to the thread.

    Thanks,
    Michael

  • Stretch Ledford

    April 4, 2011 at 2:33 am

    I had the same problem, exactly, and discovered that the sequence settings were mismatched. FCP was looking at the same source files, but interpreting them differently on the different scratch disks. Hope this helps.

    ——————-
    Charles “Stretch” Ledford

    Motion: https://vimeo.com/channels/stretchphoto

    Photography: https://StretchPhotography.com

    Blog: https://VeryStretchy.com

    Tweets: https://twitter.com/stretchphoto

    Facebook: https://bit.ly/bGWxM4

    Vox: 888-320-4002 804-643-6747

    STRETCH PHOTOGRAPHY • VERY STRETCHY PRODUCTIONS
    “North America and the Entire World”

  • Kevin Carlson

    September 10, 2013 at 10:03 pm

    I’m having the exact same issue too, years later…
    I’m using the same project file in two locations, one in my bay where the media is on a SAN, then I will move the file to my laptop and use the same copied media on an external drive.

    The audio files recorded with a Marantz flash recorder are off–usually seems to be 45 seconds(!) whereas the audio files recorded with a different recorder (maybe a Sound Devices?) reconnect fine. The video is from a 5D.

    This baffles all of us in the department.

    Seems to be a very rare problem, but if anyone has any ideas please comment!

  • Andrew Fettis

    October 5, 2013 at 7:58 pm

    Hi

    I’ve been having same problem and have found a solution.
    So I’m using last released version of FCP 7.0.3, working on H264/ 23.98 Video (naughty naughty no transcoding) with audio 48Mhz 24bit. My audio was recorded separately to video recorded on a 7D. I’m not sure what the sound recording device was, since I received the files by online transfer in 2 batches. All was fine until I had to move the media onto another drive, both were FW800. Then when I try and relink I get Attributes of original don’t match. Strangely one set of audio was fine, and the other not only has slightly different time-codes but different durations. I try re-importing the offending sound files, (not relink) to see what duration FCP thinks they are now. It’s consistent with its new duration. I try stripping off timecode in QT pro. No good. Try changing all the easy setup etc, no change.

    SOLUTION
    I take all the audio into compressor, it thinks it’s the original duration, and so I export all as a aiff, same bit rate as original, relink the new files and all is back to normal, phew. It’s probably a error with how NTSC assigns frame rates to audio. I’m in the UK so normally everything is 25 and we don’t get this problem, even audio is all 25 fps. This was all media from the US, and at 23.98. Because of the variable frame rates employed in the US I believe frame rates are more flexible on the audio?

  • Kevin Carlson

    October 10, 2013 at 4:11 pm

    Thanks for sharing!

  • Andrew Fettis

    October 10, 2013 at 5:35 pm

    UPDATE
    The compressor solution only seemed to work once, then not again. The real solution to this is from posts elsewhere on creative cow. My computer and most of it’s programmes (including Compressor) is set to work 25P (British standard). So actually what’s happened is the some of the sound was imported when the project (easy setup) was set to 25P and some when is was set to the new frame rate I’m working with for this project only, which is 24P. Hence the different durations. WAV files don’t inherently come with a frame rate attached, they change according to environment. So what I’ve had to do is make sure easy setup is 24P, then re-import all wavs at 24P, then where necessary re-sync the sound. It’s easyset up which determines which frame rate WAV (and other) sound files are imported as.

    So I suspect that all those having problems have changed their easy setup and forgotten not realised, which is why the sound goes all over the place.

  • kate ebson

    October 30, 2013 at 3:03 pm

    thanx andrew, that was really helpful!!!

  • Juli Nimechchyni

    May 9, 2015 at 5:12 pm

    Hey Andrew,
    can you post the link to where this info exists on other forums?

    I’m having a hellofa time with this problem.

    It’s even the same project file that I open on a new computer (running Yosemite vs. the old system of Snow Leopard) and the project set-up has the same settings on the old and new, but the audio files are reading as the wrong length!

    Is it something about how the hard-drive is formatted?

    When I open the same project file with corresponding media files on an older external hard-drive, but with the same new computer, it works fine. When I copy the files to the computer and open it from there, it slips out.

    Thanks for any more info!

Viewing 1 - 10 of 10 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy