Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Apple Final Cut Pro Legacy Final Cut Pro 6 keeps quitting unexpectedly

  • Final Cut Pro 6 keeps quitting unexpectedly

  • Randy Heeren

    May 14, 2015 at 6:07 pm

    Hello all, I could really use some help. I know, you read that correctly, I’m using FCP 6. Please don’t tell me to just upgrade my version; I’m not in a position where I can do that.

    My computer is also fairly old, but it still works fine to me:

    Mac 10.4.11
    Processor: 2 x 3 ghz dual core intel xeon
    Memory 5 GB 667 MHz DDR2 FB-DIMM

    I am working with Apple ProRes 1920 x 1080 .mov files. I can actually import these files okay. At first everything works fine. However, as I continue to edit, such as adding footage to my timeline, or just playing my source files in the viewer, FCP “quits unexpectedly.” This occurs after only about a minute or so of editing, sometimes longer. It also quits even when I’m not performing any edits and just letting FCP stay open.

    I realize that I’m attempting to mesh old technology with new, and there are bound to be issues there. I’m asking if there’s anything I can do to make this work. Perhaps messing with my video codec or something? Or what else should I be looking for?

    Thanks in advance.

  • Mark Suszko

    May 14, 2015 at 7:57 pm

    When it quits, can you call up the error log and look it over? Most of it will be as incomprehensible as stock market stats, but if you see the words “kernal panic” in there, besides other things, it points to a situation where the system is running out of memory for some reason. That app and OS used real memory and something called “virtual memory, which was imitation RAM created virtually from unused hard drive space. If the drives get too full or too fragmented, you run out of virtual RAM and the system crashes.

    I’d look at your boot drive and see if it is more than 70 percent full. Next, open disk utility from the Apple Utilities folder, run a diagnostic on the boot drive and your scratch drive, where your AV files reside (you DO have those on their own drive, preferable a RAID 0 or RAID5, right?) Run a hardware test on your RAM, see if that’s still working right.

    Then look up how to trash preferences, do that. Can’t hurt.

    Now, see if the problem remains.

    And are you sure your file are all pro res? No unexpected H.264 files around, and no graphics bigger than 4000 pixels on a side?

  • Randy Heeren

    May 15, 2015 at 12:31 am

    I see. Something similar popped up in the error message:

    Exception: EXC_BAD_ACCESS (0x0001)
    Codes: KERN_INVALID_ADDRESS (0x0001) at 0xedd1c845

    So I think there’s a good chance that you’re right.

    I’ve never messed with my computer’s boot drive in that way before so you’re gonna have to cut me a little slack here. I see that my computer has a volume just called Macintosh HD, which I assume is my computer’s boot drive?

    I just have other external hard drives on this mac that I don’t want to confuse with my boot drive. One of these hard drives is a 7 terabyte lacy hard drive, which I am currently storing all my original footage on. I am also using this drive as my scratch disk.

    My Macintosh HD volume only has 53 gigs free out of 232. My Lacie drive currently has 724 gigs free out of 7 terabytes. I can free up more space on these as you suggest and get back to you.

    I will also look into running the hardware test on my ram and trashing my preferences. Thanks so much for the advice!

  • Randy Heeren

    May 16, 2015 at 12:04 am

    Okay, so I cleared away lots of files on both my Macintosh HD volume boot drive and my Lacie external hard drive. Their memory usage is now as follows:

    Macintosh HD memory: 147 gigs available of a total of 232gigs

    Lacie memory: 1.11 tb available of a total of 7.28 tb

    Unfortunately after I freed up this space, FCP continued to crash on me. Maybe I need to clear more space on my Lacie? It is where I’m currently storing my scratch disks.

    Not sure what I’m missing here. I did trash my preferences, and I made sure that all of my files are indeed 422 prores and not h264 (as well as all of them are 1920 x 1080 in dimensions, with nothing larger than that)

    I will try to run the hardware test on my ram, as well as run the disk utility on the drives. Haven’t had time to do that yet.
    This has never happened to my other projects of mine on this computer, probably because my source video files are smaller and of lesser quality. So memory is still probably an issue. Maybe I should mess with my memory and cache system settings in FCP? It says my application memory usage is at 100%, and my still cache is at 21%.

    Please help me people >< *edit* I ran disk utility on my Mac HD, and it said that it needs repair! I hope this is what's been causing my crashes. In the process of doing the whole fsck -fy thing now, will post again about how it goes *2nd edit* Well I fixed my Mac HD, and my lacie is verified, but I'm still crashing when I edit! Arrrg.

  • Roger Poole

    May 17, 2015 at 10:57 pm

    Randy, I’m pretty sure you need to trash your FCP preferences. The easy way is to download Preference manager and use that to do it easily. When you run PM choose only FCP, as by default all the studio apps are selected.

    Download it here.

  • Randy Heeren

    May 18, 2015 at 8:45 pm

    You both were right!

    I actually did trash my preferences a few days ago, only then I did not select “Final Cut Express” in the list of programs to trash. Since you brought it up again, I decided to try selecting both FCP and Final Cut Express while I trashed my preferences. I have been editing all day and have not crashed once since doing this!

    Thank you both so much. It’s possible that the problem could return, but I think I’m out of the woods. You can mark this as solved now.

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy