- June 11, 2018 at 7:48 pm
I’m going crazy.
Is there any way I can know the exact requirements of specific versions of software like FCPX?
Right now, I need to know if FCP 10.4 (not 10.4.1 or more, 10.4) is compatible with Motion 5.2 and Compressor 4.2, or if I really need to buy the versions that have been released at the same time, that is to say Motion 5.4 and Compressor 4.4.
I’m often looking for that kind of information and I’m never able to find it, since everyone is pushing you to buy the latest version.
- June 12, 2018 at 9:30 pm
you’d probably be better of asking this on the FCPX forum.
this one is for FCP7 and under.
oops – didn’t see Shane;s post.
Log in to reply.