Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro X File > Share never gets to second dialog

  • File > Share never gets to second dialog

    Posted by Bill Rabkin on November 19, 2020 at 7:05 pm

    In FCPX 10.4.10 I’ve just finished a video of a jazz concert. I selected File > Share > Master File and entered the name I wanted for the .mov file. When I clicked “Next,” instead of displaying the file browser dialog FCPX simply closed the Share dialog and that was the end of File > Share. It never gave me the chance to select a location for the shared movie.

    I decided to delete Preferences. I quit FCPX, held down Command+Option and clicked the dock icon. FCPX displayed a popup message asking me if I wanted to delete preferences. I clicked Delete Preferences. FCPX opened and presented its “What’s New” display. It had opened untitled.fcpbundle, and the recent-files list was empty, so it seemed that FCPX had indeed deleted my preferences.

    Unfortunately, the File > Share problem remained.

    I’m not certain that FCPX really deleted preferences. When I inspected Preferences, on the Destinations tab I found a Compressor destination that I had added, and on the Playback tab I found the “Rendering: Start after” setting to be 0.3 seconds, which I had set years ago. (I thought the default for this was 0.5 seconds.)

    I’m in the middle of editing several other projects, so I would prefer not to upgrade FCPX to 10.5 right now if I can avoid doing so. Have you any suggestions about how I can get FCPX to proceed when I click Next during File > Save?

    Bill Rabkin replied 3 years, 7 months ago 2 Members · 2 Replies
  • 2 Replies
  • Jeremy Garchow

    November 19, 2020 at 7:20 pm

    Try making a new export destination. (File > Share > Add Destination, and then drag “Export File” to the list on the left). Rename it something cool, setup the parameters you’d like, and try sharing again using that setting.

    If that doesn’t work, try trashing the “com.apple.FinalCut.UserDestinations.plist” in the User > Library > Preferences folder. To get there go to Finder, Hold option, select the “Go” menu while still holding option, and then choose Library and Navigate the preferences folder.

  • Bill Rabkin

    November 19, 2020 at 8:32 pm

    Thanks for your suggestion, Jeremy. Very strange…I went back into FCPX to follow your instructions. Before I did so, however, I tried File > Share…and it worked normally! I have no idea why it took a brief holiday earlier today and then went back to work.

    I will keep your suggestion in mind in case FCPX goes wonky again.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy