Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Creative Community Conversations fcpx won’t playback

  • fcpx won’t playback

    Posted by Adam Dewhirst on June 3, 2013 at 12:48 am

    Ever since i deleted some effects in a projects folder called analysis (to free up disk space) i basically cannot use fcpx at all. it won’t display any of the video from events or projects in the viewer and when i go into a project and hit the space bar to play i get the beach ball from which there is no return. This is the same for all events and projects now not just the one i deleted the effects from. I have tried trashing preferences, updating to the latest version of fcpx and safeboot but nothing makes any difference.

    i am using an iMac 2.5ghz 12 gb memory.

    I was wondering if anybody out there had some advice about how to get it working again?

    Adam Dewhirst replied 10 years, 3 months ago 3 Members · 10 Replies
  • 10 Replies
  • Nikolas Bäurle

    June 3, 2013 at 2:22 am

    Did you delete render files? You can’t delete effects in the project folders. You shouldn’t be deleting files in Xs folder structure anyway, but do it from within the software.

    If you went into the folder structure and deleted other files by accident, it’s very possible that you screwed something up in the projects.

    If you have corrupt project or events reinstalling X and safebooting won’t help, since it will always try to open that corrupt project. If you have all your projects connected and open X, a corrupt project will cause painful beach balling and bring X to crash…

    I would start by hiding the project you deleted files from, you can use Event Manager X for this. Then open X and it should open your intact projects, its very unlikely that all your projects are corrupted.

    “Always look on the bright side of life” – Monty Python

  • Adam Dewhirst

    June 3, 2013 at 2:54 am


    thanks for your response. yes i deleted render files in both the projects and events. I have tried opening and playing totally unrelated projects using event manager. I would understand if It was only the project i intially removed the effects from that was beachballing but it is now every single project and event i open and there is not even an image showing up to play in the viewer.

  • Nikolas Bäurle

    June 3, 2013 at 3:52 am

    You could disconnect all projects and events, then open X and by default it should create a new event in you internal drive, if you haven’t done that already.

    Deleting render files, even manually shouldn’t cause any problems. If you reinstalled, safebooted and deleted prefs, and nothing works maybe you need to reinstall the OS as well.

    Do you have FCP Legacy installed on the same partition as X? Are you using any third party plugins?

  • Adam Dewhirst

    June 3, 2013 at 4:08 am

    hi nikolas,

    I’ll try doing what you say and disconnect all projects and events and create a new event.

    If i reinstall the os will i lose my old projects and events?

    i don’t have fcp legacy installed, that was on a different computer and i don’t use any third party plugins apart from event manager and 7tox.

  • Charlie Austin

    June 3, 2013 at 5:52 am

    This is sort of boilerplate advice, but before you reinstall the OS (in theory your projects should be OK as long as you don’t wipe the drive during install) Try looking in the console, it may give you a clue as to what’s happening.

    Quit FCP X, then open the console. Start FCP X. When it craps out, note the time. Then, in the console, select “all messages” in the upper left. in the search field (upper right) type “final cut” (no quotes) to filter the list. find the time stamp entry from when FCP X crapped out, or just look at what it’s logging if the beachball is still spinning. What’s it say?


    ~”It is a poor craftsman who blames his tools.”~
    ~”The function you just attempted is not yet implemented”~

  • Adam Dewhirst

    June 3, 2013 at 9:29 am

    so i hid everything else, opened up a brand new session with an auto created event, imported some footage and as soon as i try and play it : beachball. at the time activity monitor said i had 9gb worth of free memory.

    Charlie, what do you mean by console?

    I have now reinstalled fcp x and still have the same issue. everything i’ve done for the last year or so cannot be used. I don’t understand how apple can get away with selling this crap. I feel like demanding my money back as well as compensation for the last year of work.

  • Nikolas Bäurle

    June 3, 2013 at 10:57 am

    The console is in the utilities folder in your Applications.

    I’ve been using X since its release and I’ve never had any problems, other than small bugs once in a while, and there’s plenty of people on this forum using it successfully. And I always move stuff manually. Even though I recommend it, I still haven’t gotten around to buying Event Manager X;) You could have this problem with any NLE.

    Your work is not lost, if you reinstall your OS just make sure you have everything backed up to your external drive.

    Last year I had a weird problem when, after disconnecting my TV, having used it for Motion, its viewer simply disappeared, reconnecting it to the TV didn’t work , reinstalling Motion didn’t work, deleting FCP Legacy didn’t work. I ended up reinstalling my OS and everything was back to normal. These thing can happen.

    Do you have friends or some place nearby using X? Connect your Projects there, they should work.

    I doubt your projects are corrupt, simply deleting render files should not cause this. There’s probably something funky going on with X and Lion.

  • Adam Dewhirst

    June 3, 2013 at 11:17 am

    hi, thanks for your response,

    sorry if this is basic but just how do i reinstall my os. i’m sure it was on there when i bought it from the mac store?

  • Nikolas Bäurle

    June 3, 2013 at 12:31 pm

    Don’t worry It had me confused last year as well…

  • Adam Dewhirst

    June 3, 2013 at 10:14 pm

    thanks nikolas,

    i’ve now reinstalled my os but it hasn’t made any difference. i’ll create a new user account and check to see if my disk has failed but after that i’m getting very close to purchasing premiere pro so i can actually do some work.


We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy