Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Letters to the COW Team Edit button?

  • Edit button?

  • John Cuevas

    January 15, 2016 at 3:00 pm

    Hey all,

    Did we lose the ability to edit posts? Just wondering, thanks.

    Johnny Cuevas, Editor

    “I have not failed 700 times. I have succeeded in proving that those 700 ways will not work. When I have eliminated the ways that will not work, I will find the way that will work.”
    —THOMAS EDISON on inventing the light bulb.

  • Tim Wilson

    January 15, 2016 at 4:19 pm

    Hi John,

    We’re currently tweaking the system. For our first 18 years or so, the edit functions were extremely limited — originally zero, in fact, eventually evolving into a brief window that closed when somebody replied to that post.

    We recently experimented with an unlimited timeframe for editing posts, which led to considerable abuse. When we started getting complaints that threads were becoming difficult to follow because of the number of edits — such as when posts quoted other posts that no longer contained those posts — we realized that we’d gone too far.

    Typical forum practice across the web is closer to our modified original policy: a brief window, 10-15 minutes, that closes when a post has been replied to. This is consistent behavior in forums in many areas of interest, some of which also don’t allow editing at all, some of which require a user to publicly post the reason for editing their post, and some of which include a link to the original, unedited version of the post.

    The ultimate goal is to find the balance between flexibility and stability. We’ll keep working on it!


    Tim Wilson
    Creative COW

  • Kalleheikki Kannisto

    January 17, 2016 at 3:11 pm

    I don’t get any edit opportunity, even that 10-15 minute window. So I can’t fix anything if I make a mistake?

    I just posted a half a sentence which

  • Kalleheikki Kannisto

    January 17, 2016 at 3:12 pm

    Well, you get the idea.

  • Tim Wilson

    January 18, 2016 at 7:38 pm

    Hi Kalle,

    You should definitely be seeing an Edit button after you make a post. Can you try logging out and logging back in first, then make a test post in the Test Post forum forum to see if it’s still missing.


  • Kalleheikki Kannisto

    January 21, 2016 at 10:29 am

    Hi Tim,

    There’s only an edit option when you post the first post in a thread, and that is above the post. With reply’s there’s no such option that I can find anywhere.

    Here’s the first post with the option:

    Here the subsequent replys right after posting:

  • Abraham Chaffin

    January 21, 2016 at 5:16 pm

    Hit the “Reply” button to go to the “readpost” page. The edit button will show up on this page for you in the same spot as the progenitor post, if you own the post. Hope this helps!


  • Kalleheikki Kannisto

    January 22, 2016 at 6:43 pm

    Doing it that way I do get the “edit” button, but when I click on it I get the message “You are not authorized to edit this post” even though I clicked the button on my own post.

  • Abraham Chaffin

    January 22, 2016 at 6:54 pm

    Which post are you experiencing that with?


  • Kalleheikki Kannisto

    January 23, 2016 at 4:55 pm

    It was this one:

    I just tried it in the Photoshop forums, and this time worked.

    Edit: Come to think of it, it was probably not within the 10-15 minutes after posting but later.

Viewing 1 - 10 of 10 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy