Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Compression Techniques Converting a clip with dual AAC stereo tracks and maintaining two separate stereo tracks

  • Converting a clip with dual AAC stereo tracks and maintaining two separate stereo tracks

  • Max Newman-Plotnick

    March 11, 2013 at 7:50 pm


    I have a documentary client who has a set of Skype interviews they would like to use in a piece. They were captured using a basic video capture program and each clip has either 2 mono tracks or 2 stereo tracks (it depends on the clip). On each clip, one of the tracks is audio from the interviewer’s side of the camera and one is from the interviewee’s side. However, they made the mistake of recording the audio as AAC, which of course cannot be read by FCP7. What I want to do is transcode the audio and video so I end up with clips that still have either 2 mono tracks or 2 stereo tracks (i.e. identical to the original audio set-up), but in LPCM, AIFF, or WAV format — anything I can use in FCP. The issue is that sometimes there is distracting noise in one of the environments, but not the other, as often happens with webcam interviews, and we want to be able to maintain the separateness of the audio tracks so the sound mixer doesn’t have to deal with that mayhem.

    I’ve tried going through both Compressor and Adobe Media Encoder, but I always get something that has the audio mixed down to one stereo or one mono track so the interviewer and interviewee are together in the same track. This happens even when I use the variety of 4-chan output settings in Compressor. It gives me 4 audio tracks, but instead of two separate stereo pairs, or even 4 separate mono tracks it gives me two mixed mono tracks and two totally blank tracks.

    So, I tried bringing the clip (still with the original AAC audio in the separate tracks) into FCP, adjusting FCP’s audio output settings in Sequences->Settings so it would output to two stereo pairs. Then I set the stereo pairs from the clip to go to the respective outputs and sent the sequence to Compressor. However, when Compressor had finished its encode the clip didn’t have ANY audio. The picture was fine, but no audio. I assume this is because FCP couldn’t read the AAC and didn’t know what to do with it or didn’t send it to Compressor, but I don’t know enough about these kinds of encoding issues.

    The client very much wants to maintain the separate audio tracks and I am trying to find some way to do this. Is there anyone out there who has dealt with a similar problem? Did you find a workaround? How did you do it?

    Thanks very much in advance!


  • Mark Spano

    March 12, 2013 at 5:13 pm

    Here’s an idea but haven’t tried it so I don’t know if it will work. Try opening the original in QuickTime Pro. Choose Show Movie Properties and highlight the audio tracks. From there, you can assign each track to a separate output (Left, Right, Center, LFE, etc.). This is to fake out the encoder on the next step (Compressor), where you can encode multi-channel and have the tracks get separated.

Viewing 1 - 2 of 2 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy