Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Avid Media Composer Constantly getting Exception: ‘DIDReader::XraiseUnexpectedStreamStatus async file system error’ when trying to consolidate material from location to location

  • Constantly getting Exception: ‘DIDReader::XraiseUnexpectedStreamStatus async file system error’ when trying to consolidate material from location to location

  • Jimmy See

    October 30, 2017 at 7:53 am

    Having tried this now on a number of different destination drives I’m now pretty sure it’s not the place I’m attempting to consolidate to’s storage that’s the issue, though it’s been the same source drive everytime so I can’t rule that out.

    There doesn’t seem to be much rhyme or reason to it. I think it might be when I’m trying to consolidate XAVC intra clips shot on the sony FS7, but it’s hard to narrow down. It’s incredibly annoying because it’s very hard to find out where in the batch of selected clips to consolidate, the error occurred at which makes it very hard to figure out what media is causing the problem and what material out of the rest of the batch I can still consolidate.

    All the information I’ve been able to find about that specific error seems to be very old and never has anything to do with my circumstances. I’m just trying to copy media from one sequence on to another drive using show reference clips. It constantly happens during these consolidation operations and there seems to be no sign of ever finding a means of stopping it.

    Can anyone help? this is a really pernicious problem.

  • Brent Marginet

    October 30, 2017 at 4:11 pm

    Have you checked to see if you are using the correct AMA XAVC Plugin Version.

    You should be Transcoding rather than Consolidating your Media if I properly understand what you are trying to do.

    Consolidation is mainly meant for “Consolidating” a finished Sequence with handles to save space and for Archival Purposes.
    Transcoding is meant for converting your media from it’s original Codec to an Avid DNx Codec.

    I see far to many posts about people Consolidating there Footage when they really should be Transcoding it.

    \”MY MEDIA/PROJECT MOTTO: If you think three copies of your Media or Projects are enough. Take a moment to place a value on them and then maybe add two more.
    Hard Drives are now stupidly cheap. A RE-SHOOT AND YOUR TIME AREN\’T.\”

  • Jimmy See

    October 31, 2017 at 12:47 am

    Thanks Brent, I actually am intending to consolidate specifically, not transcode. These are finished sequences cut in this codec using Avid media brought in to the project via AMA linking then consolidating. This workflow was tested prior to project start. The idea is to transfer all materials from a cut to a separate drive.

    I’m discovering the problem now a couple of months ahead of online by doing some more small scale tests to look for hiccups prior to the actual online beginning. For testing, the machine I’d actually be using for this task was not available so unfortunately this issue, which seems to be restricted only to my machine only, is affecting the plan because consolidation won’t work reliably, so I’m trying to sort it out now. Ultimately we should be okay because the consolidation stage doesn’t actually need to happen on this machine, but it is very confusing why this is happening and I’d prefer to try and sort it out just in case.

    The plugin was the latest available at project start in June and used for bringing the media in to the project via consolidation. The issue interestingly enough doesn’t occur in that context, only when attempting to use consolidate for the purposes of moving Avid media from drive to drive.

  • Jimmy See

    October 31, 2017 at 1:37 am

    I should say ‘for initial testing’, that is the first batch of tests I did prior to project start, the machine I’m now using was not available. I’m now doing further testing with this machine and have run in to the issue decribed. Hope that clears it up.

  • Brent Marginet

    October 31, 2017 at 2:19 am

    What version of MC do you have and what version was on the other system.
    Have you tried going back to an older version of MC to see if it fixes the problem.
    Are both systems Mac or PC or is there one of each.
    Have you checked what the HD your Consolidating to is Formatted as and what type of Partition Table it has. I would recommend a GUID Partiton Table.

    Have you tried deleting all of the Databases in the MXF floder(s) and letting Avid rebuild them. I’ve run into odd issues a couple of times going from Mac to PC or PC to Mac and trashing all of the Databases fixed those issues.

    Just some suggestions to try, hope one of these fixes the problem.

    \”MY MEDIA/PROJECT MOTTO: If you think three copies of your Media or Projects are enough. Take a moment to place a value on them and then maybe add two more.
    Hard Drives are now stupidly cheap. A RE-SHOOT AND YOUR TIME AREN\’T.\”

  • Jimmy See

    October 31, 2017 at 4:04 am

    Actually, thanks for the suggestions, but I had a thought as to the cause that actually would be easier to test quickly and with minimal disruption so I thought I’d give that a shot before diving in to your suggestions. It turns out to have been down to a PCI usb 3.0 card we’re using. Explanation below for interest.

    I recalled that the machine I’m using, an HPz800 that we’re renting and which has had a few customisation since it was originally purchased by the owner, has always had a few issues with USB 3.0 ports which weren’t part of the original machine and are add-ons in the form of a PCI USB3.0 card. Though I’m forced to use it everyday, I’ve always directed some suspicion toward it, which looks like it might have been well founded now.

    I figured that that error, mentioning ‘async file system error’ taken literally did imply some kind of issue to do with two things that should be in sync with each other, but weren’t. I’d also experience issues in other circumstances with similarly cryptic error messages for which I could find no relevant info but which also mentioned things relating to streams, and mentioning the words ‘sync’ and many of them talking about audio strangely enough. These error messages sound from their wording like they’re describing the types of issues I’d be more familiar with seeing related to networked storage but as this is local it sounded like similar problems occurring between the computer and the local storage with regard to pulling data across in a manner where timing and synchronisation streams was important and was going awry. I don’t really understand why it would apply to consolidating as that seems to be a process of copying files one stream at a time linearly from one location to another but I just ignored that. I knew the USB 3 connection was iffy, so I just tried to plugging the the drive in to the USB 2.0 slots, which would be connected to the machine’s motherboard directly, not any 3rd party cards and lo and behold, it consolidated a large batch of media just fine (but of course, real slow).

    This appears to be the result of some sort of obscure incompatibility or compromised functionality of that particular usb 3 card and the machine in to which it’s installed. I would mention what manufacturer it is but I can’t seem to find that information in the device manager. I’m fairly sure this is the issue, but wouldn’t be able to pin that down very thoroughly since the card seems to work fine in other circumstances, file copying using the OS is fine, as is most situations using drives plugged in to this USB 3.0 card for pretty much any task. It seems however that the consolidate process in Avid, though essentially a file copy operation, uses USB 3.0 in a very specific way that isn’t working here with this add-on card. That’s not entirely outside the realm of possibility or a big surprise to me, I’ve found nebulous issues like these crop up on machines with USB 3 cards added in by PCI and which originally had only usb 2.0 ports. Strange problems manifest in in very specific instances that 99% of users wouldn’t come across using the card. Sucks I can’t use USB 3 for consolidating now because USB 2 is damn slow, but at least that seems to have nixed the issue, and the actual consolidating of finished sequences stage would likely not be done on this machine anyway.

  • Brent Marginet

    October 31, 2017 at 5:28 am


    I do have to say that I stopped buying cheap USB 3 Cards a few years back because of random, annoying, anomalous issues that would crop up when I was using them. Most of the issues I ran into were with ProTools so I bit the bullet and put Sonnet USB Cards in all my systems instead and have not had any issues since then. There cards are stupidly overpriced at up to five or six times the price of the cheaper cards but in the end so many time consuming problems have gone away that they’ve ended up saving me loads of time and money.

    I think the problem is that the cheaper cards have very little or no buffer/cache on them and this leads to issues with handshaking and bidirectional communications between devices. Even though Avid and ProTools seem to be moving data in only one direction I believe that they are quite frequently looking for feedback from devices via handshaking. If they don’t receive it on demand then issues arise.

    This is just a theory but who knows maybe I’m actually barking up the right tree with this convoluted theory.

    \”MY MEDIA/PROJECT MOTTO: If you think three copies of your Media or Projects are enough. Take a moment to place a value on them and then maybe add two more.
    Hard Drives are now stupidly cheap. A RE-SHOOT AND YOUR TIME AREN\’T.\”

  • Jimmy See

    October 31, 2017 at 5:59 am

    I really have no idea whether the card in this system is a cheapo or something that should be better. Ultimately though, it seems to have been the case in my (admittedly quite limited) number of different experiences that USB 3 cards added to a system that doesn’t already have USB 3 on the motherboard from the get-go seems to be a problem and always seems to be this kind of a problem where you’ll never see the issue until you’ve used it for a long time in a number of different circumstances and chanced on the one combination of steps that causes the card to crap itself. It’s near impossible to test for because it’s always some situation you couldn’t predict finding yourself in until you’re in it. If you’re looking to buy one and see reviews or comments online saying “I’ve had lots of problems with this” you’ll see a hundred more from well meaning people saying “I don’t know what happened with that guy’s setup but this has worked fine for me for years” but almost certainly, they’re using it mostly for simple file copying and wouldn’t encounter the circumstances that trigger the issues which seems to happen more often to people in video production.

    I’ve seen USB 3 cards that work fine (as far as can be established) all of the time, until you plug in any kind of hard drive from the Lacie brand, I’ve seen cards that are very cheap which use generic open source drivers which seem to work in all circumstances except webcams (bizarre, but actually thankfully I’m aware of this because it was actually documented and something you’re warned of ahead of time), I’ve cards where, if one plugs in any kind of storage in to the ports during system startup, the startup is delayed by several minutes (even though Boot priority sets the system drive as default), I’ve seen cards that work fine until you plug in a hub and attempt to plug in additional devices sharing the bandwidth of one port – in which case it crashes the system, I’ve seen cards for mac pros which work fine until apple updates OSx and then it starts working totally unexpectedly in random scenarios.

    Godamn, now that I’m putting it altogether like this, I trust them even less than I used to. Stupid USB 3 cards, damn things just sitting there in the back of your machine waiting for the moment to pounce and screw up your project.

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy