Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Apple Final Cut Pro Legacy Compressor Droplets not working and showing developer icon on desktop

  • Compressor Droplets not working and showing developer icon on desktop

    Posted by Tom Matthies on February 11, 2013 at 12:13 am

    As the subject says, I have many Compressor droplets on my desktop. Today after booting the computer, the icons, rather than being the usual Droplet icons, are showing the developer application icons instead.The Droplets are also not working if I drag a file onto them.A search of the COW showed a post with the same exact problem a while ago but there were no responses to the problem. Repairing permission did no good.A few of the alias icons on my dock were messed up as well, but all I had to do to fix them was to delete and drag a new one onto the dock. I can rebuild the droplets but I’d rather find a way to repair them in case this happens again.
    The only updates I’ve make lately was to download and install Motion 5 and a Java Security Update.
    Running Snow Leopard 10.6.8

    Any ideas?


    Jesse Chapman replied 8 years, 9 months ago 6 Members · 8 Replies
  • 8 Replies
  • Neil Patience

    February 11, 2013 at 12:39 am

    I have had Compressor do some crazy things from time to time and in most cases Digital Rebellions Compressor Repair has worked.

    That said in this case it does seem that perhaps something else is at play with other icons being corrupt etc.

    However its a free App so worth a shot

    I hope it helps but not 100% confident on this one, it cant hurt though.

    best wishes

    8 Core MacPro, Kona 3, Tangent Wave, Mackie Universal Symphony 6.5 FCP7
    i7 2.7 Gig MBP (non retina) 16Gigs Ram Blackmagic Monitor Mini Symphony 6.5 FCP7

  • Rafael Amador

    February 11, 2013 at 3:24 am

    That’s nothing related with Compressor or FCS.
    Your system needs some maintenance because even the finder is unable to show the proper icons.
    I would run DiskWarrior. Try first making a Safe Boot.

  • Tom Matthies

    February 11, 2013 at 8:22 pm

    Ran Disk Warrior but it didn’t fix the problem. Interestingly, if I boot from my backup drive that I updated just before running Disk Warrior, the icons look/work fine. This is an incremental backup made with CCC so I’m assuming that something is possibly corrupt with the OS and not the Droplets themselves. Short of reinstalling the OS, is there any way to isolate and fix the problems? If I create a new Droplet, it shows on the desktop just fine.


  • Rafael Amador

    February 12, 2013 at 3:51 am

    The Droplets are very small but they have a quite complex structure. If they were just documents, it could be easily fixed with the “Open with..” function, but they are in fact applications and -at least for my self- is not easy to know what has gone wrong inside.
    You could try to compare the package contents of a droplet that is OK with he one that is not working (that’s the kind of things on what I love to waist my time), but probably will be easier to make new droplets.

    [Tom Matthies] “Ran Disk Warrior but it didn’t fix the problem. …..If I create a new Droplet, it shows on the desktop just fine.”
    Is possible that DiskWarrior is not able to fix the old droplets because the are corrupted, but may have fixed the issue that produced that corruption.

  • Mark Spano

    February 12, 2013 at 4:57 pm

    In this case, it is the Droplet application (inside the Compressor application package) that has become corrupt. I have seen this before and not been able to source why this happens. But you will notice that Compressor Repair does nothing to fix (because it operates on the QMaster engine and prefs, neither of which are the application package). You will also notice that any droplets that work on other systems will not work here, and any new droplets created on this system also won’t work.

    The solution is to find a copy of the Compressor program (from another station if you have it). Show Package Contents and you will see the Droplet application inside. Copy that Droplet application into the Compressor package on your non-working system. Voila it all works again.

  • Tom Matthies

    February 12, 2013 at 5:35 pm

    Thanks Mark. I’ll give that a try. I just rebuilt the original Droplets from the presets in my Compressor program. The came up on the desktop with the correct icons but I didn’t try them to see whether they actually worked or not. I have another system available that I can copy the Droplet app from and try that.


  • Alex Hay

    February 20, 2013 at 10:13 am

    Mark, that was a fantastic help. Had the exact same problem and it fixed it perfectly.

    Thanks a lot!

  • Jesse Chapman

    July 31, 2015 at 3:12 am

    THIS. This is the solution. Thank you so much!

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy