Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects composited render never looks like beauty render

  • composited render never looks like beauty render

  • James Harris

    July 8, 2014 at 12:33 am

    I simply want my composited render to look exactly like my beauty render but when overlaying the 2 final pictures on top of each other in After Effects, there is always a slight difference. As for my composited layers, it’s super simple consisting of one scene render of my foreground 3D objects with mia_sky “use background” checked ON and no texture plugged so the backgrounds is pure black and another render of my mia_sky background with all the rest hidden. I have “pre-multiply” checked on in the render globals and when importing to After Effects I check “premultiplied with black” in the import footage settings. I don’t understand why I don’t get the exact same result as my beauty render. What am I doing wrong?

    Here is a link to the project so if you check the EXR renders in the image folder, and composite them you should see the difference. I also attache an After Effects projects in the same folder where comp1 shows the difference between the 2 results (comp2 is the background and foreground combined together):

    https://www.filefactory.com/file/667…ition_issue.rar

  • Walter Soyka

    July 8, 2014 at 12:14 pm

    Your link above does not work.

    Walter Soyka
    Designer & Mad Scientist at Keen Live [link]
    Motion Graphics, Widescreen Events, Presentation Design, and Consulting
    @keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]

  • James Harris

    July 9, 2014 at 12:19 am
  • Walter Soyka

    July 9, 2014 at 3:40 pm

    [roy achkar] “I have “pre-multiply” checked on in the render globals and when importing to After Effects I check “premultiplied with black” in the import footage settings. I don’t understand why I don’t get the exact same result as my beauty render. What am I doing wrong?”

    The rendered foreground element provided actually has straight alpha.

    Walter Soyka
    Designer & Mad Scientist at Keen Live [link]
    Motion Graphics, Widescreen Events, Presentation Design, and Consulting
    @keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]

  • James Harris

    July 10, 2014 at 1:43 am

    that can be the case, because when rendering the image out of maya, i am checking the “premultiply” option. Any ideas?

  • Walter Soyka

    July 10, 2014 at 4:14 pm

    [roy achkar] “that can be the case, because when rendering the image out of maya, i am checking the “premultiply” option. Any ideas?”

    Yet, it is the case.

    I am not a Maya user, so I can’t help you on that end.

    Look at your foreground EXR file — in interpret settings, change the alpha interpretation to ignore. If it were premultiplied, the fully-transparent areas would be black. However, you see the background, indicating straight alpha.

    Walter Soyka
    Designer & Mad Scientist at Keen Live [link]
    Motion Graphics, Widescreen Events, Presentation Design, and Consulting
    @keenlive [twitter]   |   RenderBreak [blog]   |   Profile [LinkedIn]

  • James Harris

    July 13, 2014 at 12:49 am

    when I do this, the fully transparent pixels (so in my case the gray and blue area) show the background and not a black color. And its identical to the beauty render. Does this mean that maya is outputing a straight alpha and not pre-multiply?

Viewing 1 - 7 of 7 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy