Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe After Effects Color shift when I ‘Create Shapes From Vector Layer’

  • Color shift when I ‘Create Shapes From Vector Layer’

  • Brice Munn

    March 4, 2021 at 10:33 am

    I have artwork in an AI file, color set to RGB and NOT using spot colors.

    When I ‘Create Shapes From Vector Layer’ in AE the color shifts considerably. The RGB values in AE are completely different, so I have to copy and paste fills from AI. This is extremely frustrating as I have lots of fills and strokes in my artwork.

    Seems to have started after the latest AE update.

    Any ideas?

    Software spec:

    • macOS Big Sur 11.0.1
    • After Effects 17.7.0 (Build 45)
    • Illustrator 25.2

    System spec:

    • Mac Pro (2019)
    • 3.2 GHz 16-Core Intel Xeon W
    • 192GB 2933 MHz DDR4 RAM
    • AMD Radeon Pro Vega II 32GB Graphics Card

    Thanks in advance!

    Brice

  • Robert Müller

    March 4, 2021 at 5:11 pm

    Weird, I never noticed this. Anyway, here is what did the trick for me:

    – Check your AI color settings (under “Edit”) and look for your RGB color space, in my case its sRGB IEC61966-2.1

    – Check your project settings in AE (little rocket icon) and see what color space is used under “Color”, for me it was none. I set that to the same as in AI and now the color values match for my document.

    Be sure to save your project before switching color spaces, cause I just had a hard crash after I switched the color space and then tried to convert an AI file to shapes. Might be a bug?

  • Brice Munn

    March 5, 2021 at 9:55 am

    Hi Robert,

    Thanks so much for your help, but unfortunately I’m still seeing different colour values in AE. I wonder if you could give my screenshots a once over to see if I understood your instruction?

    1 – AE Project Settings

    2 – Shape in AE created by ‘create shapes from vector layer’, note RGB fill AE generated

    3 – Shape in AI, note fill I selected is different to AE

    4 – AI Color Settings

    *Update: Since taking the screenshots I installed bridge and used it to synchronise color settings across Creative Cloud, but I’m still seeing the shift in RGB values in AE.

  • Robert Müller

    March 5, 2021 at 10:54 am

    Hi Brice,

    strange, these are the exact settings i used. What are your settings regarding the AI footage itself (interpret footage -> Color)? Maybe there are mismatched color settings

  • Brice Munn

    March 5, 2021 at 11:11 am

    Interpret footage settings match too. Strange 🤔

    *Update: I have since tried checking ‘Preserve RGB…’ in the interpret footage dialogue, which results in a complete crash when I then try and convert to shapes. When I say complete crash, I mean it doesn’t even manage to write a log file and I have to power cycle the machine to force quit AE. Buggy!

Viewing 1 - 5 of 5 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy