Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D cloner render instances disables Mograph Selection tag?

  • cloner render instances disables Mograph Selection tag?

  • David Patterson

    April 19, 2013 at 6:47 am

    I have a cloner object that I am using the Mograph Selection tag on to (1) hide some of the clones, and (2) change the color of some clones with the Shader Effector. When I enable “render instances” on the cloner, the hiden clones remain hidden, but all clones adopt a single color. With the Shader Effector, I am able to color clones individually.

    Am I doing something wrong (probably) or is this a limitation to the “render instances” with the cloner? I’m guessing the render instances wants ALL clones to be identical, which may be why they all adopt a single color.

  • Dan Conrad

    April 19, 2013 at 3:29 pm

    According to the C4D help,

    “Render Instances
    Enable this option if the objects generated by the Emitter should be optimized with regard to memory usage, i.e., an almost infinite number of renderable Render Instance should be rendered. For Clones that are nestled in one another, this option only needs to be enabled for the Parent Clones of the objects to be cloned.

    So, put the Cloner inside another Cloner set to “1” and switch on Render Instances on that one. This seems to circumvent the problem. Project Memory is the same in both instances on a setup I just tested so although it seems to be a hack I’m not sure it optimizing things any better.

    http://www.mographcandy.com
    Twitter: @mographcandy

  • David Patterson

    April 19, 2013 at 5:33 pm

    I may be misinterpreting your advice, but I don’t have clones within clones. I am using a single cube to create a cloned wall of cubes

    To this clone, I added one mograph selection tag to hide some cubes (with the volume effector scale set to zero). I added two mograph shaders to apply two different colors, and a second mograph selection to isolate where one of the mograph shader color (blue) appears. (The first mograph shader applies the yellow color to all cubes, the second mograph selection isolates where the second mograph shader applies blue to specific cubes).

    When I enable the “render instances” button on the cloner object, the second mograph shader is ignored.

    The result is that the mograph selection that hides cubes still works, but all cubes end up with the first mograph shader color. Does the “render instances” button assume all cubes will have all the same color properties, and thus, ignore the second mograph shader, or mograph selection tag?

  • Dan Conrad

    April 24, 2013 at 1:32 pm

    Sorry for the delay getting back to you. Thanks for posting the pictures. Do you have the color shader in the color channel on that material you have on the cube? Do that and move that material up onto the Cloner. That should do that trick.

    http://www.mographcandy.com
    Twitter: @mographcandy

  • David Patterson

    April 24, 2013 at 2:31 pm

    Dan – Thanks for your reply. Its working now, so thanks for your help.

  • David Cabestany

    June 24, 2013 at 10:41 pm

    I’m experiencing a sort of related problem with the mograph tag, I hope you guys can help me.

    I have a cloner object which is made of two cloner objects itself, a jigsaw puzzle, and I’m using a plane effector with a spherical falloff to animate the pieces landing into their final position. I want to make the very first piece invisible and replace it with a manually animated piece which in turn would arrive at the very end, but I haven’t been able to make the mograph tag to work properly, I’m not getting the red dots to select individual clones and even though a tag is generated, nothing is being affected by it.

    Could it be that I’m using a cloner within a cloner or that my cloner objects are referencing xref files? I have used mograph selection tags in the past and never had a problem with them, in fact I just tried it in a dummy file and it worked as expected. I’m completely lost as to why is not doing what’s supposed to.

    Anyone can help?

  • Dan Conrad

    June 27, 2013 at 1:02 am

    i understand the issue you are dealing with. Cloners within Cloners can create problems. I can’t come up with a solution for you. You might want to bump this question over to Mograph.net. Also, Tim Clapham has a nice Jigsaw tutorial on the Maxon Youtube page. Maybe you can get some ideas for workarounds there.

    https://www.youtube.com/playlist?list=PLE83DE106187F1C73

    http://www.mographcandy.com
    Twitter: @mographcandy

    Some contents or functionalities here are not available due to your cookie preferences!

    This happens because the functionality/content marked as “Google Youtube” uses cookies that you choosed to keep disabled. In order to view this content or use this functionality, please enable cookies: click here to open your cookie preferences.

  • David Cabestany

    June 27, 2013 at 3:09 pm

    Thanks Dan, I’ll check out mograph.net for an answer.

    I’m following Tim’s tutorial, I just wanted to add a personal touch to my own exercise, but I also think it is because it’s a cloner inside a cloner.

    Best,
    David.

Viewing 1 - 8 of 8 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy