Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Adobe Premiere Pro Capturing video from Canon Vixia HV 30 HD

  • Capturing video from Canon Vixia HV 30 HD

  • John Williams

    December 8, 2008 at 6:23 pm

    I just purchased a Canon Vixia HV 30 HD camcorder and cannot seem to capture footage in either HD or DV formats. This camera is too new to be listed in the Device Control list of camcorders and Adobe tech support said there is no way to add it.The best thay said I can do is to import the footage into Windows Moviemaker and then import those files into Premiere. Can anyone think of a workaround for capturing directly into Premiere.




  • mike velte

    December 8, 2008 at 9:10 pm

    The problem is you expected things to work right out of the box. Change your attitude and you should be able to capture just fine.

    1. If you shot in HDV AND want to capture in HDV you must have the camera set to HDV AND have “Down convert” turned off AND be in a HDV Project preset.

    2. If you shot in HDV and want to capture as DV, set the camera to DV mode and turn on “Down Convert” on and be in a DV Project Preset.

    3. If you shot in DV mode make sure the camera is in DV mode AND you are in a DV Project preset.

  • Tim Johnson

    January 9, 2009 at 2:34 pm


    I was able to transfer video from my HV30 to CS4 Adobe Premiere Pro.

    I had filmed with the 1080i, 25 frames per second mode.

    I am new to Adobe Premiere (as well as filming) so my explanation may be a bit stupid.

    1. Anyway, when starting up Adobe Premiere and starting a new project, in the General tab I set Video, Display Format to “Frames”. I don’t know if that’s necessary.

    2. On the General tab I also set Capture, Capture Format to “HDV”.

    3. When I click OK, a new window, “New Sequence” pops up. Under “HDV”, I select “HDV 1080i25 (50i)”. What the exact meaning of this is I couldn’t tell you. On that same window, there are two more tabs, “General” and “Tracks”. I don’t know what to do there.

    4. After clicking OK, Adobe Premiere’s main windows pop up. I select Capture in the File menu and the Capture window pops up.

    5. On the Settings tab to the right, I set Device Control, Device to “DV/HDV Device Control”.

    6. In the same area I click the Options button and a small window pops up. There I set the Video Standard to PAL (since my HV30 captures PAL video). Device Type: Standard. I also set the Device Brand to Canon. I set Timecode Format to “Non-Drop Frame”. OK.

    7. Back in the Capture window, in the Logging tab, in the Capture section, I set Handles to 25 frames.

    8. I click “Tape”.

    That works for me. I get a huge mpeg4 file.

    If somebody can clarify something that would be very appreciated.

  • Jay Noggle

    April 11, 2009 at 10:22 pm

    Has anybody been able to confirm that this line of Canon camera is supported by Premiere?

    I am using Premiere Pro 2 at home and CS3 at a school I teach at.

    The school is able to use 3 of these cams on loan from a local agency.

    A question for Mike Velte: You mention in this thread to set the DV settings in the camera to be able to capture in DV even though the footage was shot in HDV. I could find nothing in the PDF manual to make this happen. Do you have any further info/insight. I did find some info stating that Premiere does not support the AVCHD codec. If this is the case, which codecs/cameras does it work with as far as HDV is concerned?

    As these are not my cameras and I am only using what is provided, I am trying to obtain either a simple work-around, or info on where we need to go next!

    Thanks! Jay

  • John Wise

    April 30, 2010 at 1:35 am

    I just wanted to add to this thread a possible fix for anyone working with the following specs:

    Windows 7 (64-bit)
    Canon Vixia HV30
    Adobe Premiere Pro CS4

    I was having the same issues with Adobe not picking up the footage. I spoke with Canon tech support and there were a couple of settings I need to change in both the Camera settings and Adobe Premiere Pro CS4.

    Camera Settings – Make sure in the menu settings of the canon in playback mode you have Autodetect set instead of HDV. You’re footage will still be in HD, but Autodetect lets Premiere (and Windows) more easily choose the setting automatically. Also, change the next playback setting 2 to DV Device Locked.

    Premier Pro CS4 Settings – When you initially start a new project, select the HDV folder and then HDV 1080 30fps (unless you filmed in 25 or 20 then pick those). Now, in the Capture windows, click on Settings and make sure you have 1) NTSC or PAL, 2) Canon, 3) Standard, 4) Non-Drop Frames. Change it from Timecode to just plain Frames in the drop-down box. Then, this is the most important setting, in the Logging tab, click on HDV – settings and change it to DV. This is the key. If you have it on HDV, you can control the camera but nothing will record and you can use the screen or scene detect. You MUST have it set to DV. Again, don’t worry, you will still capture all the HD footage properly.

    This bogged me down for a while, but now I can capture perfectly with Adobe Premier Pro CS4 using Scene Detect. Try it out and you will rest easy going forward. Good luck!

  • Shamus Coneys

    June 24, 2010 at 12:15 am

    Hi there, your post was very informing. What an odd way to have to do it.

    I myself am having issues with my capturing.

    All is the same as you but I have a MAC.

    Is there a different set of instructions or any tips you can hand over??
    I tried the way it worked for you, but I did not have that luck.

    Premiere Pro cs4

    Keeps saying capture device offline!

    Thank you SO much

    Shay in NC

    Thank you so much!!

  • John Wise

    June 30, 2010 at 7:43 pm

    Sorry, I’ve never used a MAC before in my life. I can’t imagine the settings in Adobe are any different from Windows.

    First off, does your computer actually see your HV30 device? Windows 7 creates the driver automatically – that’s why there are no Windows 7 drivers on the Canon website. I have no idea how drivers work for Mac computers, you may need to download them from Canon.

    Again, just make sure the camera settings and adobe settings are setup correctly from my last post and it should work fine. If not, call the Canon support and they will walk you through how to capture properly – that’s what I did.

    Good luck!

  • Tim Johnson

    July 1, 2010 at 10:24 am

    I used a Mac. So my clunky explanation from above is for a Mac.

  • Enrique De la Garza

    July 27, 2010 at 7:21 am

    Hi, sorry for changing the subject but i have a problem With the exporting of an HD video….
    I Film with a canon vixia HF R10 at 1080p 30fps,the files i get are .mts files

    When i import them to premiere pro CS4, everything looks fine and smooth….. when I click the export button, a window pops up asking me for the settings, I choose format quicktime, h.264 compression , 720p frame size,etc..

    So when it comes to set the bitrate, I have tried a lot of different settings, 1500kbps , 4000kbps, 8000kbps, and 20000kbps!
    the point is that when it renders it looks pixelated and choppy ):

    Thanks! i hope you can help

  • Bob Dix

    October 15, 2010 at 12:48 pm!reply.jspa?message=2944623

    This is a bit late ,may help?

    Freelance Imaging & Video

Viewing 1 - 10 of 12 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy