Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Blackmagic Design can’t install version 11.6 on big sur

  • can’t install version 11.6 on big sur

  • Georg P. Mueller

    November 13, 2020 at 9:11 am

    I have installed Big Sur (I know, I know, but no current project going on at the moment and thought, ‘what the heck’). Video Desktop stopped working for my ultra studio. Downloaded the current version 11.6, uninstalled the previous driver and tried to install the new ones.

    I always get stuck at a popup saying “Blackmagic Design Driver Approval Required. Please click on “Allow” Blackmagic Design drivers in Security and Privacy in System Preferences and click Continue to complete the installation.”

    But there is no ‘allow button’ anywhere in Security and Privacy Settings. It just doesn’t show up. I have uninstalled the driver, rebooted, re-installed, even went through the previous version 11.5.1 (which installs fine but doesn’t work) and back to version 11.6.

    Any ideas how to get this going?

  • Nathan Reopelle

    January 30, 2021 at 5:32 pm

    I’m curious to see if you solved this problem. I know there is an update to 11.7 (even 12.0 as I write this), which probably fixed it. However, I am running big sur, 11.7 and I am getting the same thing.

Viewing 1 - 2 of 2 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy