Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Media Encoder Can’t get H.264 files smaller than ~5MB out of Media Encoder.

  • Can’t get H.264 files smaller than ~5MB out of Media Encoder.

  • Matthew Ross

    March 7, 2017 at 2:58 pm

    I have an eight second 1500×844 video I have to deliver as h.264 and the file size has to be a max of 2.5MB. No matter what I’ve tried, I simply CANNOT get a file smaller than about 5MB to render out of Media Encoder. I’ve dropped the bitrate as low as 0.25mbps just to troubleshoot, and the file STILL ends up around 5MB (with the actual video quality looking like garbage, as expected at that bitrate). It’s as if in the finalizing stage of the encode AME is adding some kind of default data overhead or something like that.

    Things I’ve tried:

    • Make sure not to export audio at all (the master is video only).
    • I’ve tried CBR, 1-pass VBR, and 2-pass VBR.
    • I’ve tried targeting about 2.5mbps (which is around where I should be targeting for an eight second video to end up around 2.5MB), and all the way down to crazy low bitrates. I tried this for both max and target bitrates when applicable.
    • I’ve used Media Encoder’s built-in H.264 codec, but also TMPGEnc’s H.264 plugin for AME.
    • I’ve tried rebooting.
    • I’ve tried exporting straight out of Premiere instead of sending to AME’s queue.
    • I’ve tried encoding from the Premiere timeline as a source, as well as a very high bitrate (~50mbps) already-rendered H.264 file (I wanted to try a DNxHD or HR file as a source but I couldn’t get that codec to accept 1500×844 as a resolution).
    • I’ve tried encoding from as well as encoding to a local drive in addition to over a network (didn’t think that would make a difference but I was at my whit’s end).
    • I have not yet tried reverting to an earlier version of AME.

    Each time, as I watch Windows Explorer, as AME gets to the end of the encoding, the file size looks like it’s going to end up right where it should be based on the bitrate I set. But, as the file is finalized, boom: it jumps up to 5MB or higher, as if some kind of overhead data is being added in the finalize stage. When I look at the finished file’s specs in MediaInfo, it lists the video bitrate as expected (for example, 2,500kbps if that’s what I targeted), but then it lists the “overall bitrate” as ~7,400kbps (and again, there is no audio track). What’s with the phantom additional bitrate?

    In the end I had to download Handbrake to export the file. And when I used the same source, and set the target bitrate to 2,500kbps, I got pretty much exactly the file I was expecting: 2.44MB.

    I tried searching for this issue both here and just in Google, but maybe I’m just not using the right terminology because so far I have not found a single other post mentioning this problem. I also plan on posting this as a bug report on the Adobe site, but I wanted to post here just in case there was something really dumb I was doing wrong.

    My specs:

    Media Encoder version 2017.0.2
    Windows 7 Enterprise (64 bit) with Service Pack 1
    Intel Xeon CPU E5-2587W v3 @ 3.10GHz
    64GB RAM
    NVIDIA Quadro M6000 GPU

  • Ricky Barrow

    March 7, 2017 at 3:31 pm

    I just had to deliver a :15 spot H.264, MP4 and it had to be under 2MB – I was requested to deliver it 960×540 and I was able to do this using (and slightly adjusting) the Android and/or Apple preset – 960×540 23.976fps. I was amazed it looked as good as it did. I did not try adjusting to your pixel dimensions though.


  • Matthew Ross

    March 9, 2017 at 1:51 pm

    Thank you for your response. I was excited to try one of the presets you mentioned thinking that maybe there was something about how I had been doing it previously that was just incorrect, and that a preset could rule that out. Unfortunately, even using the presets I’m getting the same results.

    First I tried various presets for Apple, Android, and even Kindle, but modified them so that they were the correct resolution for my project. No change; I was still getting the jump up in file size at the last moment, and MediaInfo was showing the “phantom bitrate” that simply didn’t make sense compared to the video bitrate.

    Then I tried just using one of the presets without changing it at all, even though it wasn’t going to give me the resolution I needed. I tried the “Android Phone & Tablet – 960×540 29.97” preset, and didn’t touch and thing, and still got the same result: video bitrate says 1,500kbps, but the overall bitrate says 6,578kbps, and the file ends up being 6.27MB, way bigger than it should be.

    Then I tried installing an older version of Media Encoder, CC2014 (version 2014.0). No change, still getting the file size jump at the end and the “phantom bitrate.”

    Oh well, off to Adobe I go.

  • Matthew Ross

    March 9, 2017 at 2:36 pm

    Well, I finally found the answer; I found find a post on the Adobe forums that answered the question. I had tried searches before but figured I was just not using the right terminology or something, and sure enough, the post that I found it under was just titled “Exporting H.264.” It’s one of my pet peeves when people use non-descriptive or vague subject headings in help forums.

    Anyway, on to the solution: sure enough, AME was adding a data overhead at the end of the encode: the metadata sidecar file! Once I went into the Metadata button at the bottom of the export settings panel and changed the Export Options from “Create Sidecar File” to “None,” that solved the problem. Makes perfect sense now; wish I’d thought of it before!

  • Ricky Barrow

    March 9, 2017 at 2:39 pm

    Thanks for posting the answer – I didn’t check that setting when I posted … my setting was already at none. Good catch1


  • André Felipe Oliveira Novais

    February 25, 2021 at 8:21 pm

    Thankyou a lot, i was strugling, since i need render a huge list to very specify device, and getting the same problem. I’m using the 2018 ame, in metadata, you can change the preservation rules so you do not nee chang agains in the next projects.

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy