Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Adobe Premiere Pro Can’t click and grab ANYTHING in the project window

  • Can’t click and grab ANYTHING in the project window

    Posted by Eric Suquet on May 27, 2022 at 8:14 pm

    I’m using the the most up to date premiere pro on the most up to date mac operating system.

    First off, this isn’t the issue where I can’t click and drag a clip from a bin to a timeline because I don’t have a video layer selected. MANY people seem to have had that problem, and it’s making a google search for the fix to MY problem impossible.

    All of a sudden while in the project window, I can’t click and grab any clip, sequence, or bin and move it anywhere. It highlights but then I can’t move it. I usually work in list mode, but the same problem exists in icon mode. If I switch it to “freeform” mode, I can grab the item but it won’t let me move it out of the confines of the window.

    Is this a bug in the latest update, or did I click something somewhere accidentally that I can unclick? I’ve checked to make sure that it’s in “write mode” (a setting I just discovered).

    Rich Rubasch replied 1 year, 5 months ago 4 Members · 4 Replies
  • 4 Replies
  • Ann Bens

    May 29, 2022 at 11:38 am
  • Jeffrey Fish

    August 22, 2022 at 11:41 am

    I didn’t find this was a preference issue for me but rather a timeline that was being stubborn. I created a new, clean timeline and pasted everything from the “bad” on inside the new one and the problem went away. Far as I can tell, the only thing different about the “bad’ on was that I had performed a auto-transcription-caption on it.

  • Eric Suquet

    August 29, 2022 at 1:22 pm

    For me, it ended up being bad ram. I replaced (and doubled) the installed ram and things are working well now (knock on wood).

  • Rich Rubasch

    January 1, 2023 at 3:49 pm

    I had this same problem, except odd things like my forward space key did not advance the timeline marker forward…only back worked! Also some of my keyboard shortcuts just stopped working. I have Option-D set to duplicate anything in the project window. It just stopped working after the latest CC22 update. Running Catalina so can’t load CC23 yet. I did the shift launch and it worked for a while, but now it’s back again. Never happened since CC was born. Have to think it’s a new (and exciting) ghost in the machine!

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy