Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Boris FX Boris RED trips over 50fps progressive. Any tips?

  • Boris RED trips over 50fps progressive. Any tips?

     David Esp updated 12 years, 9 months ago 2 Members · 6 Posts
  • David Esp

    October 25, 2009 at 8:55 pm

    I tried loading a short (15 second) clip into Boris Red 4.3.3 but it crashed.

    The clip was 1440×1152 (2xDV in both directions, from resolution enhancement), PAL widescreen PAR, 50 fps, progressive. It was encoded by HuffYUV in an AVI container. It plays OK in Windows Media Player and Sony Vegas but not in VLC Player.

    Played with Boris project sizes, e.g. “Custom” 1440×1152 and then of 720×576, but same problem in either case. Crashed straight away.

    Works OK on 25 fps progressive version of the same footage. Is this a known issue with 50p e.g. is there a framerate limitation or only for frames of the size I have been presenting? More especially, is there a work-around?

    Machine is a Mac Pro running XP Pro under bootcamp. It has 8GB RAM, only 630MB used when Red is runnng.

  • David Esp

    October 25, 2009 at 9:32 pm

    Succeeded with same clip when encoded with Avid’s DNxHD (a QuickTime codec) instead – Boris happily “walked” with this (not “tripped”).

    Nuisance though – it means I have an extra stage in my workflow, transcoding from AVI-HuffYUV to QT-DNxHD. The previous stage is only capable of outputing AVI.

    Any change of a fix for this please?

  • David Esp

    October 25, 2009 at 11:00 pm

    …except that as far as I can see, the DNxHD codec only allows a limited selection of combinations of resolution, framerates and field types. And of course these don’t include 1440×1152.

    So I’m blundering in the dark a bit here.

    I tried encoding with DNxHD’s “1080p/25 DNxHD 120 8-bit” and GSpot confirms the result is actually (seen at least as) a 50 fps file, 1920×1080. And in a Sony Vegas project of 50fps, each frame does look different, so maybe it’s even real. But I had forgotten, HD aspect ratio differs from PAL widescreen, so I get a pillarbox.

    Not such a good workaround after all…

    Maybe some lossless codec other than HuffYuv ?

  • David Esp

    October 26, 2009 at 6:36 am

    Current workaround that “mostly” (not entirely) works: Get previous stage to scale to HDV (1440×1080), don’t care about aspect ratio (use all pixels), save as Cineform (NeoHD version 4.6.0), input that to Boris, export from Boris to Cineform. Cineform renders faster than DNxHD because it is multithreaded (can see it happening on Task Manager). Also the way I used DNxHD at least, Boris froze at the end of rendering, but with Cineform that did not happen.

    Had to use AVI-DirectShow as opposed to AVI-VfW because with the latter, HuffYuv was refused on the basis of unacceptable dimensions while for Cineform, the rendered product consisted only of crazy (though beautiful) moving blurry vertical stripes. Looked OK on the Preview while rendering. Got same effect when just a straight movie, no Optical Stabilization.

    The result was OK apart from the first 70 frames, which, at my 50fps progressive, corresponds to 1.380 seconds into the timeline) where the output appeared divided into four rectangles, the divides not being centralised. This same section of the original (input) file did not have that artefact, nor was it visible in the preview, only when playing the render externally (e.g. in Windows Media Player or in Sony Vegas). Same “quarters-ish” effect observed (again, in first section only) when no Boris effects applied, just the movie output unaltered, and with no issues having been visible in Boris’s Preview. Tried exporting to HuffYuv (which works OK from DirectShow) instead of Cineform but still got the “quarter-ism”. So it’s not specific to either one of these codecs.

    “It don’t come easy…” (George Harrison) ..but.. “you might get what you need” (Rolling Stones)

  • Matt Mullen

    October 26, 2009 at 2:20 pm

    Hey David,

    Lot of info here…

    What is the nature of the crash? Is it a freeze? App crashing out? Does it give you an error message?

    I’d like tot est the file myself if possible. If you could do you have a small piece (under 5MB) you can send to me?

    My e-mail is


  • David Esp

    November 5, 2009 at 4:30 am

    My best workaround so far, in case it helps anyone else:

    I didn’t expect it, but (on my Windows system) Cineform appears not only under AVI (DirectShow and VfW), where I get problems exporting, but also under Quicktime (QT), for which exporting works OK. Having exported to QT-Cineform, Cineform’s HDLink app can then be used to re-wrap it to become an AVI, as some windows apps prefer.

Viewing 1 - 6 of 6 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy