Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Forums Maxon Cinema 4D Baking in joints

  • Baking in joints

     Nick Smith updated 1 year, 1 month ago 2 Members · 3 Posts
  • Nick Smith

    May 8, 2020 at 9:50 pm

    Hi All,

    I’m having an issue I can’t solve without screwing up my models.
    I’ve got some animation loops made using IK and controllers that I need to export for Unity. The problem is, when I export to .fbx that the control mesh comes with it, but if I remove the controllers then the joints won’t move. When I bake in the joints to keyframes the whole model goes crazy.
    It there a way of doing this I’m just missing or a step I haven’t thought of?
    Using R18 btw.

    Thanks,

    Nick

    Nick Smith

    \”So long, and thanks for all the fish.\”

    http://www.anarkyanimations.co.uk

  • Sam Treadway

    May 9, 2020 at 4:49 am

    Middle click select the entire joint hierarchy in the object manager.
    Open up the Timeline and in the Timeline’s menu goto Edit > Selection > Select all Objects
    Then in the menu goto Functions > Bake Objects.
    Make sure to select ‘Create Copy’ and ‘Clean Tracks’ and then any parameter sets needed.
    Export the copy using the file menu within the Object manager.

  • Nick Smith

    May 9, 2020 at 8:54 am

    Hi Sam,

    Thanks for the help.
    Strangely enough it was having those ticked that was messing with the model. I unticked them and everything worked fine.
    Thanks though 🙂

    Nick Smith

    \”So long, and thanks for all the fish.\”

    http://www.anarkyanimations.co.uk

Viewing 1 - 3 of 3 posts

Log in to reply.

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy