Creative Communities of the World Forums

The peer to peer support community for media production professionals.

Activity Forums Avid Media Composer Avid Media Composer won't launch

  • Avid Media Composer won't launch

    Posted by Marcus Taylor on December 11, 2023 at 7:35 pm

    I have a subscription with Avid, which has updated my Media Composer to 13.8.2. I have Mac OS Ventura 13.6.2. Unfortunately, when I launch/start my Media Composer, it quits once it has run through various initialization stages. Has anyone else gone through this and discovered the solution? Is it the Titler tool again?


    (On a previous version, I had Avid actually remove the Titler since it was crashing a lot)


    Had I known that Avid would upgrade my MC in the bg I would have stopped it since I can see that the matrix tells me that 13.6.2 Ventura is not approved yet. But maybe 13.5 is?


    Thoughts anyone?

    Thanks in advance

    M

    MacBook Pro M1 Max 32GB Ram

    Robert Ober replied 2 months ago 2 Members · 2 Replies
  • 2 Replies
  • Marcus Taylor

    December 23, 2023 at 5:54 pm

    Update:

    When I reinstalled MC now, I followed the previous advice from an Avid Tech when I had licensing issues. Basically, I removed the AvidTitler+ plug in (after opening up Package contents). Now MC opens up, and I go to the Main project page and can open up a Project without a problem.

    Why should I have to do this? I can’t believe other editors have this problem. What might it point to a problem on my Mac?

    Thoughts?

  • Robert Ober

    December 29, 2023 at 2:35 pm

    There may be some kind of bug related to plugins. On whatever I was running before .12 I had to move the Pro Tools plugins out of their folder on at least one of my machines. Most annoying. Seems to be OK now.

    MC is of course not perfect, but it has come a long way in the last few years.

    Hang in there,

    Robert

We use anonymous cookies to give you the best experience we can.
Our Privacy policy | GDPR Policy